Pressing Delete Key doesn't delete the Table cell.

VERIFIED INVALID

Status

()

Core
Editor
P3
normal
VERIFIED INVALID
18 years ago
17 years ago

People

(Reporter: Srinivasa Rao Borusu, Assigned: Joe Francis)

Tracking

Trunk
mozilla0.9.3
x86
Windows NT
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [behavior])

(Reporter)

Description

18 years ago
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.0; Windows NT; DigExt)
BuildID:    2000101014

I set the composer preferences such that Delete key will "Remove the entire 
cell". I designed a new page in composer with table and tried to delete a cell 
by pressing the delete key. It didn't work for me as designed.

Reproducible: Always
Steps to Reproduce:

Set the Composer preferences First.
1. Launch the Mozilla browser.
2. Select Edit->Preferences->Composer.
3. Select the "Remove the entire cell" radio button under table editing frame on
   right hand side of the preferences dialog.
4. Click on OK button.

Now
1. Open a new composer window.
2. Insert a table.
3. Place the cursor in some cell.
4. Press the Delete Key.


Actual Results:  The cursor is moving to the next cell.

Expected Results:  The designated cell should be deleted.

Comment 1

18 years ago
selecting to delete a cell does not necessarily result in less cells in the
table. For example, if I insert a default table (2x2), enter text in each cell
and then select row1, cell1 and delete the cell -- the data from row1, cell2 is
shifted to the left, however, the row1, cell2 is still there
Assignee: beppe → cmanske
Status: UNCONFIRMED → NEW
Ever confirmed: true
Target Milestone: --- → mozilla0.9

Comment 2

18 years ago
If the "Remove entire cell" preference is checked, the Delete key should delete
the TD and other cells should appear to be shuffled over. If the "Maintain table
layout peference..." is checked, an empty cell should be added after the cell
deletion is finished.
This seems to be a real bug -- I think Joe already has bugs on deleting and
table issues.
Assignee: cmanske → jfrancis
(Assignee)

Comment 3

18 years ago
moving a bunch of 0.9 bugs to 0.9.1
Target Milestone: mozilla0.9 → mozilla0.9.1
(Assignee)

Updated

18 years ago
Status: NEW → ASSIGNED
(Assignee)

Updated

17 years ago
Target Milestone: mozilla0.9.1 → mozilla0.9.2

Updated

17 years ago
Keywords: correctness
Whiteboard: [behavior]

Updated

17 years ago
Target Milestone: mozilla0.9.2 → mozilla0.9.3
(Assignee)

Comment 4

17 years ago
Is that pref only supposed to be for cell selection mode?  The bug looks invalid 
to me.  Why would delete nuke a cell if you weren't in cell selection mode?  

Comment 5

17 years ago
joe's cprrect, if the text is selected, it will just delte the text, to use the
pref correctly, you would have to select the cell and then select delte.
Status: ASSIGNED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → INVALID

Comment 6

17 years ago
verified
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.