If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

[Web Console] Area outside the network traffic messages should not trigger the "Inspect Network Request" window on mouse click event

VERIFIED FIXED

Status

()

Firefox
Developer Tools
P2
normal
VERIFIED FIXED
7 years ago
6 years ago

People

(Reporter: vladmaniac, Unassigned)

Tracking

Trunk
x86
All
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

7 years ago
Build ID: 

Mozilla/5.0 (Windows NT 6.1; rv:2.0b8pre) Gecko/20101013 Firefox/4.0b8pre

==========================================================================

Steps: 
1. Make sure you have a top site opened in a tab 
2. Bring up the Web Console 
3. Browse some links in the page in the same tab 
4. Notice traffic observation messages are echoed (blue links) 
5. Left click outside one of the message 

===========================================================================

Behavior: 
Entire line containing network event is recognized as clickable area. We should be able to select only the exact link in the console. Performing mouse events outside the designated areas is confusing.

Updated

7 years ago
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 594477

Comment 2

7 years ago
This isn't actually a duplicate of bug 594477. That other bug was dealing with the problem of right clicking and having the network panel come up. This bug is talking about clicking outside of the visible "link".

Part of bug 599498 is going to dramatically change how the logging output area looks. I believe this bug will automatically be dealt with there.
(Reporter)

Updated

7 years ago
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---
(Reporter)

Comment 3

7 years ago
Change to Reopened and keeping track of this in addition to landing of bug 599498

Updated

7 years ago
Depends on: 599498

Comment 4

7 years ago
(In reply to comment #2)
> This isn't actually a duplicate of bug 594477. That other bug was dealing with
> the problem of right clicking and having the network panel come up. This bug is
> talking about clicking outside of the visible "link".

sounds like we need an enhancement bug that changes the node we attach the onclick to to avoid adding event handlers to the entire enclosing node?

Comment 5

7 years ago
I think this is that bug.

Comment 6

7 years ago
I'm thinking this should block 2.0, as it is unexpected behavior.

Comment 7

7 years ago
Patrick: does your output area work take care of this?
Blocks: 593956

Updated

7 years ago
Priority: -- → P2
(In reply to comment #7)
> Patrick: does your output area work take care of this?

Yes, it's fixed.

Updated

7 years ago
Depends on: 605621
No longer depends on: 599498
fixed by landing from bug 605621.
Status: REOPENED → RESOLVED
Last Resolved: 7 years ago7 years ago
Resolution: --- → FIXED

Comment 10

6 years ago
Mozilla/5.0 (X11; Linux i686; rv:7.0a1) Gecko/20110621 Firefox/7.0a1

Verified issue on Ubuntu 11.04 x86, WinXP, Mac OS X, Win 7 x86.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.