Open Bug 604719 Opened 9 years ago Updated 5 months ago

No warning when the downloaded file is larger than the space available

Categories

(Firefox for Android :: General, defect, P5, major)

defect

Tracking

()

REOPENED
Tracking Status
fennec + ---

People

(Reporter: nhirata, Unassigned)

References

()

Details

(Keywords: crash, Whiteboard: [strings][native-crash])

Attachments

(1 file, 1 obsolete file)

Mozilla/5.0 (Maemo;Linux armv71; rv:2.0b8pre) Gecko/20101015 Firefox/4.0b8pre Fennec/4.0b2pre
Mozilla/5.0 (Android; Linux armv71; rv2.0b8pre) Gecko/20101015 Firefox/4.0b8pre Fennec/4.0b2pre

1. go to http://www.thinkbroadband.com/download.html
2. click on the download for the 1 gb file

Expected: some sort of warning stating that the file is larger than the space available.
Actual : it will try to download and crash.

Considering that handhelds have limited space for downloads
1) if the user is unaware that the file is large it may help if there's some sort of warning before downloading a large file >75 megs.
2) if the download is larger than the space available, there should also be a notice or warning.
Note: edge case.  Android crashes, but I'm not 100 % sure if it's because of the download file size hitting the max, or something else.
Severity: enhancement → major
Keywords: crash
This isn't an edge case! It happens quite often and something to look out for since Fennec is 12MB. Brad, I remember there being a related bug, but I can't find it. Know the bug number if there is one?
tracking-fennec: --- → ?
It would be great to tell people, if we can, that they're not going to have room for the intended file.  It's very frustrating to get to near the end of a large download, only to find that you won't get the whole thing.  Presumably this is even more frustrating on mobile, where the data is more expensive.
we need a wireframe and spec.
Assignee: nobody → madhava
tracking-fennec: ? → 2.0+
madhava, marking 2.0+ since you want it.  clear it if you don't think it is that important.
tracking-fennec: 2.0+ → 2.0b3+
The current goal for this bug is: if we know the file download size, we should check disk space. If we don't know the download size, just try to save the file.

Basically, do the right thing if we can.
Madhava - can we get a wireframe for this
Assignee: madhava → wjohnston
(In reply to comment #2)
> This isn't an edge case! It happens quite often and something to look out for
> since Fennec is 12MB. Brad, I remember there being a related bug, but I can't
> find it. Know the bug number if there is one?

for what its worth, with bug 597579 we'll be downloading updates to the sd card. So you really will have to download something huge to hit this.
Whiteboard: [strings]
Attached patch WIP (obsolete) — Splinter Review
Still waiting for some UX feedback. This implements a system notification that says, "Download is too large to save", and cancels the download. I don't particularly like that message, and think maybe we need something more obvious visually (toaster popups would be nice for this stuff).

finkle, does doing this in downloads.js look ok, or do we want to handle this further up in toolkit or platform (and potentially catch other types of downloads that don't show up in the download manager)?
Attachment #489638 - Flags: ui-review?(madhava)
Attachment #489638 - Flags: feedback?(mark.finkle)
So yes - if we know the download size, let's check to see if there's room.  If
there is, it's totally transparent.  If it's too big, let's show a notification
in the place of the "Downloading" notification.

If we don't/can't know the size, let's just start downloading, as usual.

suggestion:
http://www.flickr.com/photos/madhava_work/5166616545/

tapping on the notification could take the user to the download manager, where
the download is listed as cancelled; this way, the user knows where to go to
restart it after they've cleared some space.
Comment on attachment 489638 [details] [diff] [review]
WIP

Looks good to me
Attachment #489638 - Flags: feedback?(mark.finkle) → feedback+
Attached patch Patch V1Splinter Review
We don't know the size of the file when the download starts, so I put this check into the progress listener (highjacked from the android progress bars).

Also, I need to check if  nsILocalFile::diskSpaceAvailable is implemented anywhere (on my desktop it fails). Tested by forcing it to something small for now though.
Attachment #489638 - Attachment is obsolete: true
Attachment #489918 - Flags: review?(mark.finkle)
Attachment #489638 - Flags: ui-review?(madhava)
Attachment #489918 - Flags: review?(mark.finkle) → review+
pushed (r+ is really me)
http://hg.mozilla.org/mobile-browser/rev/39e695c27751
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → FIXED
Duplicate of this bug: 518835
minor note: on the n900, ~/MyDocs generally disappears if you're plugged into a usb host (it's exported by the mass storage driver).

If you know the current transfer rate, you should be able to check to see if the available space will be exhausted within say 5 minutes at the current rate, if it is, it's probably worth warning the user. This should work for cases where you don't know the download size.
When I click on the download for the 1 gb file. I get "The connection has timed out" page. Can you please provide another webpage with files larger than 1GB?
Verified this on Mozilla/5.0 (Android;Linux armv7l;rv:9.0a1)Gecko/20110911 Firefox/9.0a1 Fennec/9.0a1

There is no warning message displayed when trying to download a file larger than the space available. I had 100 Mb free space on device and started to download the 1 Gb file from http://www.thinkbroadband.com/download.html. When memory is full, download ends with a message box that has no message in it. 

Please see also related bug #686286.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Assignee: wjohnston → nobody
tracking-fennec: 2.0b3+ → +
Product: Fennec → Fennec Native
Whiteboard: [strings] → [strings][native-crash]
Whiteboard: [strings][native-crash] → [strings][native-crash][mentor=wesj]
Mentor: wjohnston
Whiteboard: [strings][native-crash][mentor=wesj] → [strings][native-crash]
filter on [mass-p5]
Priority: -- → P5
It sounds like this is either done, or actionable. Either way it shouldn't sit at the bottom of the barrel -- it's painful for folks with low-storage devices.
Priority: P5 → --
Hardware: ARM → All
I would like to work on this bug, is this bug still open ?
Is there someone who is still a good mentor for is? Is this feature still desirable?
Flags: needinfo?(s.kaspari)
Currently there's no one who can actively mentor you here unfortunately. However if you feel like the attached patch has enough hints to get you started then let us know and we can at least find a reviewer for a new patch. Otherwise join us on IRC (#mobile [1]) and we can try to find an other bug for you.

[1] https://wiki.mozilla.org/IRC

For the "do we still want this" part I'll redirect to barbara: Making the story around downloads better has been discussed in the past. Maybe this is a candidate for this.
Flags: needinfo?(s.kaspari) → needinfo?(bbermes)
Mentor: wjohnston2000
Absolutely, glad this is surfacing again. jdm, feel free to start working on it.


NI for Joe to let him know about this as well.

https://trello.com/c/4kVrZEa1
Flags: needinfo?(josh)
Flags: needinfo?(jcheng)
Flags: needinfo?(bbermes)
I was only asking in response to comment 7. Without a mentor, I doubt it's going anywhere.
Flags: needinfo?(josh)
Flags: needinfo?(jcheng)
Re-triaging per https://bugzilla.mozilla.org/show_bug.cgi?id=1473195

Needinfo :susheel if you think this bug should be re-triaged.
Priority: -- → P5
You need to log in before you can comment on or make changes to this bug.