If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Camino crashed when attempting to upload photos to Facebook. [@ CrossbowTypeAndQualityPdePluginFactory + 32615] com.hp.print2.aio.pde.Puffin

RESOLVED INVALID

Status

Camino Graveyard
Printing
--
critical
RESOLVED INVALID
7 years ago
6 years ago

People

(Reporter: pgrace, Unassigned)

Tracking

({crash})

Details

(crash signature, URL)

(Reporter)

Description

7 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en; rv:1.9.0.19) Gecko/2010081818 Camino/2.0.4 (like Firefox/3.0.19)
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en; rv:1.9.0.19) Gecko/2010081818 Camino/2.0.4 (like Firefox/3.0.19)

Camino crashes some of the times an upload of a photo to Facebook is attempted.
OR
Camino will not allow one to search in the Browse file; The Browse file window will disappear quickly when attempting to upload to Facebook. (It doesn't do this on Safari or Firefox, so I know it's not Facebook, per se.)

Reproducible: Always

Steps to Reproduce:
1. Go to upload photo to facebook page.
2. Camino will 1) crash or 2) have the Browse file window disappear before a selection can be made.
3.
Actual Results:  
As described above; Camino will either crash or make the Browse file window disappear almost instantaneously before a photo can be chosen. 

Expected Results:  
Upload photo window appear. Choose photo file; upload to Facebook page.

Process:         Camino [83509]
Path:            /Applications/Camino.app/Contents/MacOS/Camino
Identifier:      org.mozilla.camino
Version:         2.0.4 (2010.08.18)
Code Type:       X86 (Native)
Parent Process:  launchd [143]

Date/Time:       2010-10-15 13:40:20.425 -0500
OS Version:      Mac OS X 10.5.8 (9L30)
Report Version:  6
Anonymous UUID:  4EF4B1FB-F8B4-4D58-B388-A1098C317C7B

Exception Type:  EXC_CRASH (SIGABRT)
Exception Codes: 0x0000000000000000, 0x0000000000000000
Crashed Thread:  0

Thread 0 Crashed:
0   libSystem.B.dylib             	0x94a02e42 __kill + 10
1   libSystem.B.dylib             	0x94a7523a raise + 26
2   libSystem.B.dylib             	0x94a81679 abort + 73
3   libstdc++.6.dylib             	0x9450f005 0x944c7000 + 294917
4   libstdc++.6.dylib             	0x9450d10c __gxx_personality_v0 + 1108
5   libstdc++.6.dylib             	0x9450d14b std::terminate() + 29
6   libstdc++.6.dylib             	0x9450d2b1 __cxa_rethrow + 79
7   com.hp.print2.aio.pde.Puffin  	0x1d132253 CrossbowTypeAndQualityPdePluginFactory + 32615
8   com.hp.print2.aio.pde.Puffin  	0x1d12cce4 CrossbowTypeAndQualityPdePluginFactory + 10744
9   com.apple.HIToolbox           	0x906e8bde CacheSelectionNotifications::~CacheSelectionNotifications() + 112
10  com.apple.HIToolbox           	0x905f87c0 TListData::CloseContainer(unsigned long) + 196
11  com.apple.HIToolbox           	0x90642710 TBrowser::~TBrowser() + 112
12  com.apple.HIToolbox           	0x905edab2 TBrowser::EventHandlerProc(OpaqueEventHandlerCallRef*, OpaqueEventRef*, void*) + 502
13  com.apple.HIToolbox           	0x904d613d DispatchEventToHandlers(EventTargetRec*, OpaqueEventRef*, HandlerCallRec*) + 1181
14  com.apple.HIToolbox           	0x904d557b SendEventToEventTargetInternal(OpaqueEventRef*, OpaqueEventTargetRef*, HandlerCallRec*) + 405
15  com.apple.HIToolbox           	0x904d53e0 SendEventToEventTargetWithOptions + 58
16  com.apple.HIToolbox           	0x90514e22 HIObject::Destruct() + 186
17  com.apple.CoreFoundation      	0x94bac516 _CFRelease + 182
18  com.apple.HIToolbox           	0x905862f5 HIView::DisposeSubPanes(bool) + 77
19  com.apple.HIToolbox           	0x905861ea HIView::Destruct() + 148
20  com.apple.CoreFoundation      	0x94bac516 _CFRelease + 182
21  com.apple.HIToolbox           	0x905862f5 HIView::DisposeSubPanes(bool) + 77
22  com.apple.HIToolbox           	0x905861ea HIView::Destruct() + 148
23  com.apple.CoreFoundation      	0x94bac516 _CFRelease + 182
24  com.apple.HIToolbox           	0x905862f5 HIView::DisposeSubPanes(bool) + 77
25  com.apple.HIToolbox           	0x905861ea HIView::Destruct() + 148
26  com.apple.CoreFoundation      	0x94bac516 _CFRelease + 182
27  com.apple.HIToolbox           	0x905862f5 HIView::DisposeSubPanes(bool) + 77
28  com.apple.HIToolbox           	0x905861ea HIView::Destruct() + 148
29  com.apple.CoreFoundation      	0x94bac516 _CFRelease + 182
30  com.apple.HIToolbox           	0x905862f5 HIView::DisposeSubPanes(bool) + 77
31  com.apple.HIToolbox           	0x905861ea HIView::Destruct() + 148
32  com.apple.CoreFoundation      	0x94bac516 _CFRelease + 182
33  com.apple.HIToolbox           	0x905862f5 HIView::DisposeSubPanes(bool) + 77
34  com.apple.HIToolbox           	0x905861ea HIView::Destruct() + 148
35  com.apple.CoreFoundation      	0x94bac516 _CFRelease + 182
36  com.apple.HIToolbox           	0x906262f3 WindowData::~WindowData() + 269
37  com.apple.HIToolbox           	0x9062c7a1 HIViewWrapperDef::~HIViewWrapperDef() + 37
38  com.apple.HIToolbox           	0x904d6768 HIObject::HandleClassHIObjectEvent(OpaqueEventHandlerCallRef*, OpaqueEventRef*, void*) + 274
39  com.apple.HIToolbox           	0x904d65d3 HIObject::EventHook(OpaqueEventHandlerCallRef*, OpaqueEventRef*, void*) + 55
40  com.apple.HIToolbox           	0x904d613d DispatchEventToHandlers(EventTargetRec*, OpaqueEventRef*, HandlerCallRec*) + 1181
41  com.apple.HIToolbox           	0x904d557b SendEventToEventTargetInternal(OpaqueEventRef*, OpaqueEventTargetRef*, HandlerCallRec*) + 405
42  com.apple.HIToolbox           	0x904d53e0 SendEventToEventTargetWithOptions + 58
43  com.apple.HIToolbox           	0x90514e22 HIObject::Destruct() + 186
44  com.apple.HIToolbox           	0x905508a9 WindowData::Destruct() + 697
45  com.apple.CoreFoundation      	0x94bac516 _CFRelease + 182
46  com.apple.AppKit              	0x90f15251 -[NSWindow dealloc] + 1669
47  com.apple.Foundation          	0x95d0af5a __delayedPerformCleanup + 58
48  com.apple.CoreFoundation      	0x94ba96db CFRunLoopTimerInvalidate + 363
49  com.apple.CoreFoundation      	0x94baa629 CFRunLoopRunSpecific + 3753
50  com.apple.CoreFoundation      	0x94baaaa8 CFRunLoopRunInMode + 88
51  com.apple.HIToolbox           	0x904fe2ac RunCurrentEventLoopInMode + 283
52  com.apple.HIToolbox           	0x904fdffe ReceiveNextEventCommon + 175
53  com.apple.HIToolbox           	0x904fdf39 BlockUntilNextEventMatchingListInMode + 106
54  com.apple.AppKit              	0x90eb36d5 _DPSNextEvent + 657
55  com.apple.AppKit              	0x90eb2f88 -[NSApplication nextEventMatchingMask:untilDate:inMode:dequeue:] + 128
56  org.mozilla.camino            	0x006baf8c nsAppShell::ProcessNextNativeEvent(int) + 686
57  org.mozilla.camino            	0x006daa9a nsBaseAppShell::DoProcessNextNativeEvent(int) + 40
58  org.mozilla.camino            	0x006dadf2 nsBaseAppShell::OnProcessNextEvent(nsIThreadInternal*, int, unsigned int) + 336
59  org.mozilla.camino            	0x006baa78 nsAppShell::OnProcessNextEvent(nsIThreadInternal*, int, unsigned int) + 290
60  libxpcom_core.dylib           	0x00dcc4d8 nsThread::ProcessNextEvent(int, int*) + 118
61  libxpcom_core.dylib           	0x00d95567 NS_ProcessPendingEvents_P(nsIThread*, unsigned int) + 63
62  org.mozilla.camino            	0x006daa18 nsBaseAppShell::NativeEventCallback() + 92
63  org.mozilla.camino            	0x006bb3d1 nsAppShell::ProcessGeckoEvents(void*) + 589
64  com.apple.CoreFoundation      	0x94baa40f CFRunLoopRunSpecific + 3215
65  com.apple.CoreFoundation      	0x94baaaa8 CFRunLoopRunInMode + 88
66  com.apple.HIToolbox           	0x904fe2ac RunCurrentEventLoopInMode + 283
67  com.apple.HIToolbox           	0x904fdffe ReceiveNextEventCommon + 175
68  com.apple.HIToolbox           	0x904fdf39 BlockUntilNextEventMatchingListInMode + 106
69  com.apple.AppKit              	0x90eb36d5 _DPSNextEvent + 657
70  com.apple.AppKit              	0x90eb2f88 -[NSApplication nextEventMatchingMask:untilDate:inMode:dequeue:] + 128
71  com.apple.AppKit              	0x90eabf9f -[NSApplication run] + 795
72  com.apple.AppKit              	0x90e791d8 NSApplicationMain + 574
73  org.mozilla.camino            	0x00003116 main + 306
74  org.mozilla.camino            	0x0000297a _start + 216
75  org.mozilla.camino            	0x000028a1 start + 41

Comment 1

7 years ago
This is caused by com.hp.print2.aio.pde.Puffin.

You should try complaining to HP.
Component: General → Printing
QA Contact: general → printing
Summary: Camino crashed when attempting to upload photos to Facebook. → Camino crashed when attempting to upload photos to Facebook. [@ CrossbowTypeAndQualityPdePluginFactory + 32615]

Comment 2

7 years ago
Yeah, this crash report clearly shows a problem in HP code, not Camino or Gecko code. This isn't a Camino or Gecko bug.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → INVALID

Updated

7 years ago
Severity: major → critical
Keywords: crash
Summary: Camino crashed when attempting to upload photos to Facebook. [@ CrossbowTypeAndQualityPdePluginFactory + 32615] → Camino crashed when attempting to upload photos to Facebook. [@ CrossbowTypeAndQualityPdePluginFactory + 32615] com.hp.print2.aio.pde.Puffin
(Assignee)

Updated

6 years ago
Crash Signature: [@ CrossbowTypeAndQualityPdePluginFactory + 32615]
You need to log in before you can comment on or make changes to this bug.