Don't export unnecessarily V8 headers to dist

RESOLVED FIXED

Status

()

RESOLVED FIXED
8 years ago
8 years ago

People

(Reporter: wuno, Assigned: wuno)

Tracking

Trunk
x86
OS/2
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: fixed-in-tracemonkey)

Attachments

(1 attachment)

(Assignee)

Description

8 years ago
User-Agent:       Mozilla/5.0 (OS/2; Warp 4.5; rv:2.0b8pre) Gecko/20101015 Firefox/4.0b8pre
Build Identifier: 

V8 headers are exported to dist. However, due to setting the vpath in js/src/Makefile.in and the headers being in the vpath they are found also when they are not exported. Moreover, since at least some of the header files are designated with very common names like "utils.h" and "dist" is in the search path ahead of the system headers the V8 headers may be picked up erroneously when a system header includes another system header with the same name. 

Reproducible: Always
(Assignee)

Updated

8 years ago
Version: unspecified → Trunk
(Assignee)

Updated

8 years ago
Blocks: 558799
(Assignee)

Comment 1

8 years ago
Created attachment 485852 [details] [diff] [review]
don't export v8 headers

gal, since you reviewed the v8 dtoa patch in bug 558799, you may want to have a look at this patch. If you are the wrong person, please suggest me another reviewer. The patch works with linux and OS/2, other platforms I can't test but they should theoretically build as well.
Assignee: general → wuno
Status: NEW → ASSIGNED
Attachment #485852 - Flags: review?(gal)

Comment 2

8 years ago
Comment on attachment 485852 [details] [diff] [review]
don't export v8 headers

Looks good to me. Please tryserver before landing.
Attachment #485852 - Flags: review?(gal) → review+
(Assignee)

Comment 3

8 years ago
(In reply to comment #2)
Thanks for the fast review.

> Please tryserver before landing.

Uhm, anybody to help me out? I've no checkin rights, sorry.
(In reply to comment #3)
> (In reply to comment #2)
> Thanks for the fast review.
> 
> > Please tryserver before landing.
> 
> Uhm, anybody to help me out? I've no checkin rights, sorry.

I'll do it later today.
Passed try server.  I landed it yesterday:

http://hg.mozilla.org/tracemonkey/rev/3e513dbf0882

Thanks for the patch!
Whiteboard: fixed-in-tracemonkey

Comment 6

8 years ago
http://hg.mozilla.org/mozilla-central/rev/3e513dbf0882
Status: ASSIGNED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.