layer-based popup menu failure

RESOLVED WONTFIX

Status

Webtools Graveyard
Bonsai
P3
normal
RESOLVED WONTFIX
18 years ago
2 years ago

People

(Reporter: Hugh Kennedy, Assigned: Tara Hernandez)

Tracking

({dogfood})

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

18 years ago
visiting the above (or any) bonsai URL with NN4 and clicking
on a filename "pops up" a menu allowing you to select blame, diffs, or log
info for that file.

its actually just making the "popup" layer visible with the link URL.

this dosen't work in NN6 or mozilla (as well it shouldn't)

i haven't looked into it enough to see if we can do this with CSS/HTML4/something
we *do* support.

but it would be nice if our tools didn't do things that we can use :-)
(Reporter)

Comment 1

18 years ago
something more along the lines of

http://www.shadowland.org/xbl/test3/test.html


..which is mozilla-specific, but better than NN4-specific, no?

Comment 2

17 years ago
Perhaps do something similar to what's in bug 80388...

Comment 3

17 years ago
It sucks that you have to downgrade your browser to use this feature :(

Maybe an absolutely positioned <div> with an <object> element as a child to
insert what would be shown in the layer would work.

Comment 4

17 years ago
Created attachment 60986 [details]
testing of popup div with an <object> tag inside.

Here is a simple test case that pops up an absolutely positioned <div> when the
cursor is clicked on one of the links.	It then adds an <object> element as a
child to embed content from another page (at the moment, it is pointing at the
GNOME bonsai).	Unfortunately, clicking on the link causes the content to load
within the <object> frame.

Is there a beter way to insert external content like this?

Comment 5

17 years ago
I get essentially the same behaviour by inserting an iframe rather than an
object element.

I have no idea how to get the frame to shrink to fit the content (or get rid of
the padding around the element).  Hopefully this will help someone more talented
in DHTML to fix the problem :)

Comment 6

17 years ago
If the bonsai output was changed around so that the contents of the popups were
included in the document, rather than being loaded as separate docs, the
solution to bug 80388 may be possible.  I don't know if this is desirable (it
would probably lead to duplicating the information, as old browsers would still
load the menus as separate pages.

Comment 7

16 years ago
I just commited a set of fixes for the popups to GNOME Bonsai
(http://cvs.gnome.org/bonsai/).  They use absolutely positioned iframes for
Mozilla while still using layers for NN4.

Once they are tested a little more, I'll attach our patch.

Updated

16 years ago
QA Contact: matty → timeless
(Assignee)

Comment 8

16 years ago
Any patch forthcoming from the gnome folks?

Comment 9

15 years ago
*** Bug 230011 has been marked as a duplicate of this bug. ***
QA Contact: timeless → bonsai
Keywords: dogfood
Summary: dogfood: layer-based popup menu failure → layer-based popup menu failure
Bonsai was decommissioned, closing all remaining bugs "wontfix"
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → WONTFIX
Product: Webtools → Webtools Graveyard
You need to log in before you can comment on or make changes to this bug.