If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Several crashes when trying to Sync

RESOLVED WORKSFORME

Status

Cloud Services
General
RESOLVED WORKSFORME
7 years ago
7 years ago

People

(Reporter: WonderCsabo, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

7 years ago
User-Agent:       Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b8pre) Gecko/20101015 Firefox/4.0b8pre
Build Identifier: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b8pre) Gecko/20101015 Firefox/4.0b8pre

If i sync may data with Firefox Sync, no synchronization is happening, but sometimes crashes.

Reproducible: Sometimes

Steps to Reproduce:
1. Create a new Sync account.
2. Sync.
3. Crash.



I got these crashreports. The crashes always happened just after i hit the Sync Now button.

http://crash-stats.mozilla.com/report/index/bp-26c12cd0-da1f-4aab-a9a4-206422101015
http://crash-stats.mozilla.com/report/index/bp-253beae5-7b06-4e9d-9359-709072101015
http://crash-stats.mozilla.com/report/index/bp-1bd576bf-03bd-4155-91eb-646e12101015
http://crash-stats.mozilla.com/report/index/bp-4e6bc24b-e663-474d-9aba-7a0e32101015
(Reporter)

Updated

7 years ago
Version: unspecified → Trunk
This was filed in response to bug 603388 comment 5. Apparently the behaviour occurs on an hourly build based on rev 00e90d9720c8

Please include such information in the future! Your description doesn't mention the context at all. Also please turn on logging for Sync and attach your about:sync-log.


(In reply to comment #0)
> http://crash-stats.mozilla.com/report/index/bp-26c12cd0-da1f-4aab-a9a4-206422101015

This one has a different signature so it might not be related.

> http://crash-stats.mozilla.com/report/index/bp-253beae5-7b06-4e9d-9359-709072101015
> http://crash-stats.mozilla.com/report/index/bp-1bd576bf-03bd-4155-91eb-646e12101015
> http://crash-stats.mozilla.com/report/index/bp-4e6bc24b-e663-474d-9aba-7a0e32101015

I wonder if this is at all related to compartments landing shortly before bug 603388.
Component: General → General
Product: Firefox → Mozilla Services
QA Contact: general → general
Version: Trunk → unspecified
(Reporter)

Comment 2

7 years ago
I wish to attach sync log, but as i already mentioned, i cant. The sync log is not generated at all, even with the about:config variable that you told me.

What context?

I cant tell too more. I created a Sync account, try to Sync, and Firefox crashed. Sometimes doesnt crashed , but never synced.

And another thing: when i tried to delete my account i get this error on the delete page:

An unexpected error occured. Please try again later.


I'm sorry, but quite hard to reproduce this, sometimes it's immediately crashes when i hit Sync now button, sometimes not.
(In reply to comment #2)
> I wish to attach sync log, but as i already mentioned, i cant. The sync log is
> not generated at all, even with the about:config variable that you told me.

That's strange. If I create "services.sync.log.appender.debugLog.enabled" as a Boolean and set it to true, I can go to about:sync-log and see the log (note that it takes ~10 secs after start up until Sync initiates).

> And another thing: when i tried to delete my account i get this error on the
> delete page:
> 
> An unexpected error occured. Please try again later.

Thanks for letting us know. This has been reported before, see bug 604554. I've reopened that bug.
(Reporter)

Comment 4

7 years ago
I've found the regression range:

http://hg.mozilla.org/mozilla-central/rev/e139cc2d6f0e : works
http://hg.mozilla.org/mozilla-central/rev/19cb42fa4554 : doesn't work
Here's that as a regression range pushlog link (just contains one push):
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=e139cc2d6f0e&tochange=19cb42fa4554
(Reporter)

Comment 6

7 years ago
Okay, i made some progress.

I realized, that automatic sync is not working even with e139cc2d6f0e (stucks when getting privkey) Manual sync is working (hit Sync Now button) 

On 19cb42fa4554, both manual and automatic is now working. The logs are not even created.

Here is my logs with e139cc2d6f0e:

Automatic: http://tinyurl.com/36wfpss
Manual:  http://tinyurl.com/34ktd5v

I tried on new profiles, and several new sync accounts, too. Always the same symptoms were present.
(Reporter)

Comment 7

7 years ago
This just happened when i hit the Sync Now button: http://crash-stats.mozilla.com/report/index/99ab9873-8bad-4f28-9cda-29a182101018
(Reporter)

Comment 8

7 years ago
philikon, any feedback?
(In reply to comment #7)
> This just happened when i hit the Sync Now button:
> http://crash-stats.mozilla.com/report/index/99ab9873-8bad-4f28-9cda-29a182101018

This looks like it's not related to Sync but merely triggered by it.
(Reporter)

Comment 10

7 years ago
And what about Comment 5 and Comment 6 ?
Comment 5 and comment 9 aren't conflicting.  We may be triggering a crash in other code that we weren't before.

As for comment 6, that looks like we're logging in, but we aren't due to sync.  We don't always sync on startup, and in the future we won't automatically connect until it's time to sync.
(Reporter)

Comment 12

7 years ago
(In reply to comment #11)
>
> As for comment 6, that looks like we're logging in, but we aren't due to sync. 
> We don't always sync on startup, and in the future we won't automatically
> connect until it's time to sync.

But i never can connect with automatic sync with e139cc2d6f0e.

>On 19cb42fa4554, both manual and automatic is now working. The logs are not
>even created.

Ehh, i made a typo. So, on 19cb42fa4554, both manual and automatic is NOT working at all. The logs are not even created.

It's very annoying, i'm experiencing it on three computers, new profiles, new sync accounts.
(Reporter)

Comment 13

7 years ago
Ok, refreshing the status:

Actually, Sync IS working. No crashes.

But logging is still not!

It seems not i the only person who suffer from this problem:
http://forums.mozillazine.org/viewtopic.php?f=23&t=2030369&start=75
Logging is disabled by default in b7, see http://philikon.wordpress.com/2010/11/12/sync-in-firefox-4-0-beta-7/

Original issue is no longer present, resolving.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 15

7 years ago
Strange, i added the variable before, and sync didnt work even with that. Now i just checked, the variable wasnt there, added, restarting, and now everything's just fine. (i'm using trunk build)

Thanks!
You need to log in before you can comment on or make changes to this bug.