Installing the same add-on twice in the same session makes it appear multiple times in the UI

RESOLVED DUPLICATE of bug 562922

Status

()

RESOLVED DUPLICATE of bug 562922
8 years ago
8 years ago

People

(Reporter: mossop, Unassigned)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(blocking2.0 betaN+)

Details

(Reporter)

Description

8 years ago
If you install the same add-on twice then the UI shows both installs as ready to install. The API lists them both too and in fact cancelling one will probably cancel them both but still leave on as listed.

When a new install starts for an existing pending install we should cancel the existing pending install.
(Reporter)

Updated

8 years ago
blocking2.0: --- → betaN+
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 562922
You need to log in before you can comment on or make changes to this bug.