Closed Bug 604801 Opened 10 years ago Closed 10 years ago

cfx testall on Firefox 4.0b6 triggers unresponsive script dialog, other symptoms

Categories

(Add-on SDK Graveyard :: General, defect)

defect
Not set
normal

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: myk, Unassigned)

References

Details

When I run cfx testall against Firefox 4.0b6 on Linux, the test run hangs at one point, after which an unresponsive script dialog appears complaining about securable-module.js line 353, one of my CPUs gets pegged, memory usage climbs until all memory is being consumed (then drops precipitously and repeats that cycle over and over), the unresponsive script dialog hangs, and the following exception is reported to the console:

error: An exception occurred.
Traceback (most recent call last):
  File "resource://testpkgs-jetpack-core-lib/observer-service.js", line 174, in 
    this.callback(subject, data);
  File "resource://testpkgs-jetpack-core-lib/content/symbiont.js", line 162, in _onStart
    this._window = window.wrappedJSObject;
TypeError: null has no properties

It's not clear that all of these symptoms (particularly the exception) are related, but they all happen around the same time, and the CPU/memory issues definitely go away once I force quit the test run.

Atul: any thoughts on what might be causing this?
I see this on Mac and Windows too.  Also, sometimes the unresponsive script is reported as nsHandlerService.js.
OS: Linux → All
Hardware: x86 → All
This also happens on nightly builds from before the "Cu.import is not a function" horkage (f.e. 2010-10-13).
This started with changeset 680248df0349, which added files missing from the previous checkin, d1b2b899440d, for bug 598980.

changeset:   856:680248df0349
user:        Irakli Gozalishvili <rfobic@gmail.com>
date:        Sat Oct 09 01:22:33 2010 +0200
summary:     adding missed files to d1b2b899440d

changeset:   855:d1b2b899440d
user:        Irakli Gozalishvili <rfobic@gmail.com>
date:        Fri Oct 08 18:50:51 2010 +0200
summary:     change "windows" module to use `EventEmitter` event registration model and mergin with a work for side-bar (r=avarma)


Irakli: can you also take a look at this?
Here are the last few lines of a verbose log before the hang occurs:

info: executing 'test-tab-browser.testEventsAndLengthStayInModule'
info: pass: Correct number of events fired from window 1
info: pass: Correct number of events fired from window 2
info: pass: Correct number of events fired from all windows
info: pass: Correct number of tabs in window 1
info: pass: Correct number of tabs in window 2
info: pass: Correct number of tabs in all windows
info: executing 'test-tab-browser.testTabModuleActiveTab_getterAndSetter'
error: An exception occurred.
Traceback (most recent call last):
  File "resource://testpkgs-jetpack-core-lib/observer-service.js", line 174, in 
    this.callback(subject, data);
  File "resource://testpkgs-jetpack-core-lib/content/symbiont.js", line 162, in _onStart
    this._window = window.wrappedJSObject;
TypeError: null has no properties
info: pass: Correct active tab on window 1
info: pass: Correct active tab on window 2
info: pass: activeTab setter works
I'm looking into this issue but can't really see what happens there yet. What puzzles me is that I can reproduce it by running testall but if I run all tests either for jetpack-core or addon-kit all the tests pass just fine.
Atul and I also took a look at this today, but neither of us were able to figure it out either.  At this point, we're better off backing out the fix for bug 598980, since it's the only issue blocking the 0.9 RC, and then figuring out the problem afterwards.
The Add-on SDK is no longer a Mozilla Labs experiment and has become a big enough project to warrant its own Bugzilla product, so the "Add-on SDK" product has been created for it, and I am moving its bugs to that product.

To filter bugmail related to this change, filter on the word "looptid".
Component: Jetpack SDK → General
Product: Mozilla Labs → Add-on SDK
QA Contact: jetpack-sdk → general
You need to log in before you can comment on or make changes to this bug.