If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

form assistant leaves ghost tab images over content

VERIFIED FIXED

Status

Fennec Graveyard
General
VERIFIED FIXED
7 years ago
7 years ago

People

(Reporter: tchung, Assigned: mbrubeck)

Tracking

Trunk
ARM
Android

Details

Attachments

(4 attachments, 5 obsolete attachments)

(Reporter)

Description

7 years ago
Created attachment 483799 [details]
Ghost tab images over content screenshot

When tapping on the content textboxes with tabs open, i can sometimes get ghost images of the tabs to appear

* See screenshot.  Could not reproduce on the Nexus One

Repro:
1) install nightly android build: Mozilla/5.0 (Android; Linux armv71; rv:2.0b8pre) Gecko/20101016 Firefox/4.0b8pre Fennec/4.0b2pre	
2) open a few tabs on the sidebar
3) launch a website that has a textbox, that would require tapping to open in a virtual keyboard
4) click on a search box within the content page
5) Verify ghosted images of tab thumbnails appear in the screen

Expected:
- no ghosted tab thumbnails on the content pages

Actual:
- ghosted tab thumbnails
(Reporter)

Comment 1

7 years ago
Created attachment 483800 [details]
Another ghosted tab thumbnail screenshot

Another screenshot example, this one on cnn.com search box.
(Reporter)

Updated

7 years ago
tracking-fennec: --- → ?
Duplicate of this bug: 605030
tracking-fennec: ? → 2.0b2+
Summary: [VKB] leaves ghost tab images on HTC Incredible → form assistant leaves ghost tab images over content
Assignee: nobody → mbrubeck
(Assignee)

Comment 3

7 years ago
Only the fourth and later tabs show up as ghosts - it looks like they are being pushed into a new column by the keyboard resize, and for some reason when formhelper is activated, that new column ends up overlapping the content.
(Assignee)

Comment 4

7 years ago
Created attachment 484030 [details] [diff] [review]
New tab theme

For some reason, setting "opacity: 0.5" on the documenttab element made it fail to go away when scrolled offscreen.  (Looks like a CSS or gfx bug.)  Moving the opacity from the documenttab to the thumbnail fixes this bug.

In order to distinguish between the foreground and background tabs, we then need to apply more of the new theme.  This patch:

* Applies the new theme background and button images from bug 575403.
* Changes some CSS selectors for performance reasons.
* Shrinks Sean's background gradients to 1px wide and uses repeat-x.
* Moves the close button over the left border of the tab, as shown in http://www.flickr.com/photos/madhava_work/4993009505/sizes/o/in/set-72157624962763028/

For this to look right, it should be used with Vivien's sidebar gradient patch from bug 575403.
Attachment #484030 - Flags: review?(mark.finkle)
(Assignee)

Comment 5

7 years ago
Created attachment 484034 [details]
screenshot with new theme patch

This also has attachment 484018 [details] [diff] [review] applied (sidebar and urlbar gradients).
(Assignee)

Comment 6

7 years ago
Created attachment 484038 [details]
screenshot v2
Attachment #484034 - Attachment is obsolete: true
(Assignee)

Updated

7 years ago
Attachment #484038 - Attachment is patch: false
Attachment #484038 - Attachment mime type: text/plain → image/png
(Assignee)

Comment 7

7 years ago
Created attachment 484040 [details] [diff] [review]
patch v2

Fix bugs pointed out by Sean:

* Overlay reload image on top of thumbnail, not underneath.
* Extend the tab padding to show the bevel at the bottom of the gradient.

There should also be a drop-shadow, but we are not doing that for now because of performance problems.
Attachment #484030 - Attachment is obsolete: true
Attachment #484040 - Flags: review?(mark.finkle)
Attachment #484030 - Flags: review?(mark.finkle)
(Assignee)

Comment 8

7 years ago
Created attachment 484045 [details] [diff] [review]
patch v3

Fake a shadow using a thin gray border, as suggested by mart3ll on IRC.
Attachment #484040 - Attachment is obsolete: true
Attachment #484045 - Flags: review?(mark.finkle)
Attachment #484040 - Flags: review?(mark.finkle)
(Assignee)

Updated

7 years ago
Depends on: 575403
(Assignee)

Comment 9

7 years ago
Created attachment 484066 [details] [diff] [review]
patch v4

New red close buttons from Sean.  These replace the existing close image rather than adding new images.  Renamed the close button images to end in -hdpi to match the new convention.
Attachment #484045 - Attachment is obsolete: true
Attachment #484066 - Flags: review?(mark.finkle)
Attachment #484045 - Flags: review?(mark.finkle)
(Assignee)

Comment 10

7 years ago
Created attachment 484067 [details]
screenshot v4
Attachment #484038 - Attachment is obsolete: true
Comment on attachment 484066 [details] [diff] [review]
patch v4


> #tool-star {
>-  list-style-image: url("chrome://browser/skin/images/bookmark-default-64.png");
>+  list-style-image: url("chrome://browser/skin/images/bookmark-default-63.png");

Mistake?

The new close PNGs seem large (KB). We should look at shrinking our PNGs in general
Attachment #484066 - Flags: review?(mark.finkle) → review+
(Assignee)

Comment 12

7 years ago
(In reply to comment #11)
> Mistake?

Yes.

> The new close PNGs seem large (KB). We should look at shrinking our PNGs in
> general

I'll pngcrush the images and fix the -63 before pushing this patch.
(Assignee)

Comment 13

7 years ago
http://hg.mozilla.org/mobile-browser/rev/03a6e97b5b21
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → FIXED
Verified:
Mozilla/5.0 (Maemo;Linux armv71; rv:2.0b8pre) Gecko/20101019 Firefox/4.0b8pre Fennec/4.0b2pre
Mozilla/5.0 (Android; Linux armv71; rv2.0b8pre) Gecko/20101019 Firefox/4.0b8pre Fennec/4.0b2pre
Status: RESOLVED → VERIFIED
Duplicate of this bug: 607565
You need to log in before you can comment on or make changes to this bug.