Allow Updater to apply Incremental Updates

RESOLVED WORKSFORME

Status

()

RESOLVED WORKSFORME
8 years ago
8 years ago

People

(Reporter: trappmanrhett, Unassigned)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows NT 6.0; rv:2.0b8pre) Gecko/20101012 Firefox/4.0b8pre
Build Identifier: Mozilla/5.0 (Windows NT 6.0; rv:2.0b8pre) Gecko/20101012 Firefox/4.0b8pre

Currently, Firefox's update feature pulls the full build, rather than updating just the changed (updated) components. Allowing incremental updates, would save server bandwidth and allow for faster updates on slow connections.

Reproducible: Always
(Reporter)

Updated

8 years ago
Version: unspecified → Trunk

Comment 1

8 years ago
This is WFM and I always get the incremental partial update if I'm on the build from the day before. Only if I skip a day do I get the full build, did you mean you want it to load each incremental update between the date of the build getting the update and the current one when they aren't consecutive?
(Reporter)

Comment 2

8 years ago
Yes, normally a full build isn't required unless major changes, or a new version was released. The updater should compare the user's component versions with the latest build, and only update changed files. 

Full build updates should be used when new versions (like beta 9) are released, sub versions (like Beta8 Pre rv:3) should be incremental, not full even if they are not consecutive.

Basically updates should be downloaded by component, not as a whole build.
Only update what is necessary, not everything when only one thing needed to be updated.
Um, it does download incremental updates unless there is an issue with the incremental.
Component: General → Application Update
Product: Firefox → Toolkit
QA Contact: general → application.update
This is WFM as far as application update is concerned. The policy as to whether a complete or a partial update is advertised to clients is a Firefox driver decision and any work that would need to be done would be done by release engineering since they create the complete and partial update mar files.

This bug is works for me as far as it is filed. If you would like to get the policy changed I suggest you discuss this in the dev-apps-firefox newsgroup.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.