browser_webconsole_bug_588342_document_focus.js is broken and pollutes other tests

RESOLVED DUPLICATE of bug 603610

Status

RESOLVED DUPLICATE of bug 603610
8 years ago
4 months ago

People

(Reporter: dao, Unassigned)

Tracking

Trunk
x86
All
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

8 years ago
TEST-INFO | ... | Console message: [JavaScript Error: "notificationBox is null" {file: "chrome://mochitests/content/browser/toolkit/components/console/hudservice/tests/browser/browser_webconsole_bug_588342_document_focus.js" line: 57}]

I'm seeing this message very often in various browser chrome tests.
(Reporter)

Updated

8 years ago
Blocks: 581069
(Reporter)

Comment 1

8 years ago
Created attachment 483805 [details] [diff] [review]
patch
Assignee: nobody → dao
Status: NEW → ASSIGNED
Attachment #483805 - Flags: review?(ddahl)
(Reporter)

Updated

8 years ago
Summary: browser_webconsole_bug_588342_document_focus.js pollutes other tests → browser_webconsole_bug_588342_document_focus.js is broken and pollutes other tests
There's a fix for this already in bug 603610.

Additionally, this patch does not ever close the Web Console. It fails to work. The test timeouts.

Comment 3

8 years ago
Dao:

Sorry, we have a patch I should have checked in already. in bug 603610.
Status: ASSIGNED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 603610
(Reporter)

Updated

8 years ago
Attachment #483805 - Flags: review?(ddahl)
(Reporter)

Updated

8 years ago
Assignee: dao → nobody

Updated

4 months ago
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.