If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Hotmail, msn sites, live.com and any https site is "untrusted connection" and loads blank

RESOLVED WORKSFORME

Status

()

Firefox
General
RESOLVED WORKSFORME
7 years ago
7 years ago

People

(Reporter: germeten, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

7 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2.10) Gecko/20100914 Firefox/3.6.10 SearchToolbar/1.2
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2.10) Gecko/20100914 Firefox/3.6.10 SearchToolbar/1.2

firefox keeps calling any https site "untrusted connection" and requires adding an exception but it doesn't help. The pages load blank! Please fix this or I'll need to roll back to an earlier version. Here's an email I tried sending to microsoft but they have no contancrt support email:

I cannot log in to hotmail or access any msn pages. I keep getting
blank page and the following error messages in firefox:

"This is an untrusted connection"

I add exceptions but it does not help. All msn pages load as blank.
In firefox error console, says:

Warning: Unknown property 'text-index'.  Declaration dropped.
Source File:

https://secure.wlxrs.com/~Live.SiteContent.ID/~15.3.20/~/~/~/~/css/R3WinLive1033.css
Line: 138

One of the offending scripts is: www.secure.wlxrs.com
All msn and live.compages are reported as having an unsecure
and/or "untrusted" connections and then load entirely blank. I add
them as exceptions but does no good.

And being unable to login, can't use the resources msn/hotmail
provides to blog or troubleshoot about it.

Please look into it, thank you.

germeten@yahoo.com



Reproducible: Always

Steps to Reproduce:
1.Visit an msn or live.com webpage 
2....or any https webpage
3. Firefox reports as an "untrusted connection" and requires an exception 
4. The exception does nothing, the page loads blank!
Actual Results:  
Give me a breaK

Expected Results:  
i ALREADY TOLD YOU

XP PRO, Pentium 4, dial-up
(Reporter)

Comment 1

7 years ago
I see flavors of the same problem to other users, hope you guys fix this soon.

germeten@yahoo.com
You shouldn't use a https page if the connection is untrusted.
You missed the important part in your description, why is the connection untrusted (technical details).

Please try a new firefox profile: http://support.mozilla.com/en-US/kb/Managing+profiles
(Reporter)

Comment 3

7 years ago
You missundersand me. MSN and hotmail pages are all https now, it doesn't 
matter what I want, if I try to check my email, it takes me to an https
webpage. All live.com pages have the https extension as well. If there's 
a way of changing that, please advise. A little blue field appears in 
far left of the url field that doesn't permit any changes. Just go visit
any msn, live.com page and see what I mean.
I know that hotmail/live are using https. I meant that you shouldn't try to continue if you get an untrusted connection alert without knowing the cause (for your own security).

For the bug itself:
Please create a new profile as suggested in my previous comment.
You should get an untrusted connection page if you visit a https page where you didn't add an exception. In this error page there is a part called "Technical details", click on it to see the technical details and post them here.

An additional question:
If you time and date (year !) correct on your system ?
(Reporter)

Comment 5

7 years ago
Dear Mathias;

Thanks for responding.

Well, I know hotmail is secure as it can be, and I need to check my emails there, so any "unsecure connection" prompts I get are just annoying and waste time. I've had that account over 5 years with countless emails saved and received daily, I can't just create another hotmail profile without losing
huge data. Also the untrusted connection applies to all msn, live.com pages, including technical/blog support. I can't even login because ALL connections are "untrusted." I'm not a programmer so don't know how to fix the problem anyway. I rolled back to firefox 3.5 and that didn't help. Also I disabled SSL and then other pages came up unable to load for lack of that protocol so re-enabled it.

I DID add an exception for live.com because I presumed it wouldn't load the pages unless I did so. Other non-https pages loaded fine when I added exceptions, but not msn/hotmail. If you're telling me to revoke the exception, I will, and hope that works.

Maybe it has nothing to do with firefox, but more with the companies' urls who
msn is partnering with; but firefox seems to be creating the problem by saying
connections are untrusted or unsecure when they've always worked in the past
and still do on other computers. I might finally add that sometimes hotmail uses an http and not an https, and those few times I was able to login, as in (once) yesterday.

Best regards,

dean
(Reporter)

Comment 6

7 years ago
Oh I forgot to mention I'm using yahoo until I can access my hotmail account.
Would you please send replies to: <germeten@yahoo.com>

I tried to revoke the exception certificate for hotmail but I don't know how
to do it or where in firefox the certificates are stored. All I know is I can't
access msn and a bunch of other sites because the connections are "untrusted" according to firefox. But they're just typical vanilla websites like bing, etc.
not warez or hacker sites.
I'm sorry but I can't help you if you can't answer my questions.

a) is your computer date+time correct. Don't forget the year ?
A wrong system time on your PC can cause your problems because certificates are only valid from date x to date Y.
b) please post the information from the technical details of the error message !
An example: 
https://cacert.org should cause a https error with this technical details
>cacert.org uses an invalid security certificate.
>The certificate is not trusted because no issuer chain was provided.
>(Error code: sec_error_unknown_issuer)"

Please load https://landfill.bugzilla.org/ , click on the technical details section in the error message and copy+paste it here as comment.
c) Please try a new Firefox profile (not a hotmail profile, a windows profile or something else)
The posted links should show you how to do it. - http://support.mozilla.com/en-US/kb/Managing+profiles

An untrusted connection could be a symptom that someone tries to steal your data but it could be also only a technical glitch.
(Reporter)

Comment 8

7 years ago
Thank you Mathias, problem resolved!
and what's the problem ?
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → WORKSFORME

Comment 10

7 years ago
I have the same problem but it doesn't come from the date+time stuf. Well I just have the problem with hotmail when I use it with a full-https session. They use to give ssl protection for login only but now it's for the full session. You can change it at the adress : https://account.live.com/ManageSSL.

It seems there is some special behavior with the certificate which seems untrusted. Moreover, the display (http://yfrog.com/c9hotmailsslp) is incorrect as if there were a css problem. I can't open my e-mail with the full https session.
I tried it on a computer usin Ubuntu 10.10 and Windows Xp. Now I'm using firefox 3.6.12. I think this is what I'm using on Ubuntu too. I have opened a topic on ubuntu french website but it's in french... Nevertheless you will find some pictures that may help. 
Oh, and I try it with internet explorer. There is still a problem with the certificate. But I can access my email after a few windows remaining me that the certificate is probably unsure. On Opera I have the same behavior that I have with IE 6.0.

Maybe the certificate is unsure and I hope I'm wrong because it means that someone is trying to do some MITM on my connection. But I don't think so because it occurs on two different places...

Comment 11

7 years ago
Sorry, here is the website I told you about : 

http://forum.ubuntu-fr.org/viewtopic.php?pid=3852686#p3852686
You need to log in before you can comment on or make changes to this bug.