error in form (not in IE8/Namoroka) / right aligned password hint buttons

RESOLVED DUPLICATE of bug 591619

Status

()

Core
Layout: Form Controls
RESOLVED DUPLICATE of bug 591619
7 years ago
7 years ago

People

(Reporter: ehoogeveen, Unassigned)

Tracking

({regression})

Trunk
x86_64
Windows 7
regression
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

7 years ago
User-Agent:       Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b8pre) Gecko/20101017 Firefox/4.0b8pre
Build Identifier: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b8pre) Gecko/20101017 Firefox/4.0b8pre

There are two problems with the URL above:
1) The 'year' field (third field after 'Geboortedatum:' is stretched out due to a notice about an undefined constant (this notice does not appear in either IE8 or Namoroka).
2) The password hint buttons are right-aligned with the form instead of appearing right next to the password fields - behavior here is consistent with Namoroka, but not IE8 - made worse by 1).

Either of these may be intended or a problem with the website, but the combined behavior is ... unfortunate. The restrictions on the password are rather strict, and when I first tried to fill in the page I couldn't see the password hint buttons as they were pushed off screen to the right.

Reproducible: Always

Steps to Reproduce:
1. Open the test URL in a small window.
2. Scroll down to the bottom.

Actual Results:  
Third field next to 'Geboortedatum:' is extremely long and contains a warning notice in the first entry - password hint buttons are right-aligned with the long field.

Expected Results:  
No warning message in the field (as in IE8/Namoroka) / field is capped to more reasonable length / password hint buttons show up next to their respective fields instead of being right-aligned (not sure which of these, if any, would be correct).
(Reporter)

Comment 1

7 years ago
Forgot to mention: also tested with TM/JM off, no change.

Updated

7 years ago
Severity: minor → normal
Component: General → Layout: Form Controls
Keywords: regression
Product: Firefox → Core
QA Contact: general → layout.form-controls
Version: unspecified → Trunk
I'm afraid this is basically your fault:

    <select name="jaar">
	<br />
<b>Notice</b>:  Use of undefined constant Y - assumed 'Y' in <b>D:\Websites\www.burgerpanelhilversum.nl\aanmelden\aanmelden.php</b> on line <b>727</b><br />
<option value="0" ></option><option value="1900" >1900</option>
...
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 591619
> The 'year' field (third field after 'Geboortedatum:' is stretched out

That's bug 591619.

> 2) The password hint buttons are right-aligned with the form

That's correct behavior.  Those images have this rule applied to them:

  .contentlinks img { float: right }

and then have style="float=none;" set as an attribute.  Note '=' instead of ':'.  IE in quirks mode, I believe, allows that.

So I think this is a duplicate of bug 591619, but please reopen if you disagree?

And thank you for the clear bug report!
Ms2ger, I'll bet money that Emanuel is not the page author here; he was trying to _use_ the page... ;)
Oh, and Emanuel, you may want to report the float=none thing to the page author.
(In reply to comment #4)
> Ms2ger, I'll bet money that Emanuel is not the page author here; he was trying
> to _use_ the page... ;)

Oops, sorry Emanuel!
(Reporter)

Comment 7

7 years ago
Thank you for the quick replies! I'll report the problem to the site admin (assuming I can reach them - government website and all that).
(Reporter)

Comment 8

7 years ago
For the record, I just sent them the following message (in Dutch):

"Toen ik me vandaag aanmeldde voor het burgerpanel merkte ik een paar problemen op in het aanmeldingsformulier. Hieronder volgt een beschrijving van het probleem en (deels) een oplossing.

1) Het 'jaar' veld naast 'Geboortedatum' geeft in Firefox 4 als eerste item de volgende tekst weer: "Notice: Use of undefined constant Y - assumed 'Y' in D:\Websites\www.burgerpanelhilversum.nl\aanmelden\aanmelden.php on line 727". Hierdoor wordt het veld extreem uitgerekt. Dat deze tekst weergegeven wordt is Firefox bug 591619 (https://bugzilla.mozilla.org/show_bug.cgi?id=591619), maar de tekst is in de eerste plaats waarschijnlijk onbedoeld (wellicht een waarschuwing van automatisch gegenereerde code?).

2) De blauwe (i) knoppen die informatie geven over de toegestane wachtwoorden zijn rechtsuitgelijnd door een (type)fout in de code - ze worden als bedoeld weergegeven in Internet Explorer 8, maar berusten eigenlijk op een syntaxfout. De code is als volgt: 'style="float=none;"' Dit zou 'style="float:none;' moeten zijn (voor beide knoppen).

Samen zorgen deze problemen ervoor dat de knoppen makkelijk rechts uit beeld verdwijnen, en ik had dan ook behoorlijk wat moeite om een wachtwoord te verzinnen! Ik hoop u hiermee voldoende te hebben geïnformeerd en dat de pagina gecorrigeerd wordt."
(Reporter)

Comment 9

7 years ago
The page has already been fixed :) Problem resolved!
You need to log in before you can comment on or make changes to this bug.