Editor refuses to insert a <keygen> element

RESOLVED FIXED in mozilla2.0b7

Status

()

Core
Editor
RESOLVED FIXED
8 years ago
8 years ago

People

(Reporter: glazou, Assigned: glazou)

Tracking

Trunk
mozilla2.0b7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Assignee)

Description

8 years ago
It's impossible to insert a <keygen> element in the editor using insertNode() or insertElementAtSelection(). The element is not inserted into the document tree, and there's no transaction recorded.
Blocks BlueGriffon.

Updated

8 years ago
Attachment #483916 - Flags: review+
Attachment #483916 - Flags: approval2.0?
BTW it seems like we should have tests to ensure all the elements we want to be able to insert actually can be inserted (via various methods).

Comment 3

8 years ago
(In reply to comment #2)
> BTW it seems like we should have tests to ensure all the elements we want to be
> able to insert actually can be inserted (via various methods).

Yes, absolutely.  This is among many stuff in the editor that I'm planning to write tests for post 2.0.

Comment 4

8 years ago
http://hg.mozilla.org/mozilla-central/rev/da4897bd001d
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla2.0b8
(Assignee)

Comment 5

8 years ago
(In reply to comment #2)
> BTW it seems like we should have tests to ensure all the elements we want to be
> able to insert actually can be inserted (via various methods).

Sure. Even w/o tests, that list is really easy to determine just looking at
kElements in nsHTMLEditUtils.cpp and nsHTMLEditUtils::CanContain()
Target Milestone: mozilla2.0b8 → mozilla2.0b7
You need to log in before you can comment on or make changes to this bug.