Switching tabs (or open a new one) on document load triggers window.onerror

RESOLVED INVALID

Status

--
minor
RESOLVED INVALID
8 years ago
3 months ago

People

(Reporter: noel.verschaeren, Unassigned)

Tracking

3.6 Branch

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.6; en-US; rv:1.9.2.10) Gecko/20100914 Firefox/3.6.10
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.6; en-US; rv:1.9.2.10) Gecko/20100914 Firefox/3.6.10

When focus it lost on a loading window (in a tab) window.onerror is triggered.
happens on all platforms (tested in windows and MacOS)


Reproducible: Always

Steps to Reproduce:
1. create document with next code:
<html><head></head><body>
<script type="text/javascript">
window.onerror = function (msg, url, lno) {
alert('l: '+lno+', '+msg+' on '+url);
}
</script>
</body></html>

2. open in a tab
3. when loading quickly press [CMD][tab] or just click an other open tab
Actual Results:  
Alert will show up:
l: 0, Script error. on


Expected Results:  
nothing ;-)
This is WFM using Mozilla/5.0 (Windows; U; Windows NT 5.1; de; rv:1.9.2.11) Gecko/20101012 Firefox/3.6.11, i.e. no Alert.
Version: unspecified → 3.6 Branch
(Reporter)

Comment 2

8 years ago
Did a re-test, and found out that it is probably related to firebug.
Could not reproduce it without firebug open.
Sorry for that one
Component: General → Developer Tools
(Reporter)

Updated

8 years ago
Severity: normal → minor
Resolving in this Case.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → INVALID

Updated

3 months ago
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.