Closed Bug 605164 Opened 11 years ago Closed 10 years ago

Tabs from last time shows me tabs from some time ago

Categories

(Firefox for Android Graveyard :: General, defect)

defect
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 630398

People

(Reporter: mossop, Unassigned)

References

Details

(Whiteboard: [fennec-sessionstore])

Fennec doesn't seem to remember very well what tabs I was using last time, it is currently suggesting that my last tabs was a page I was looking at two days ago. I have used Fennec multiple times since then
We delete the backup session file, which is used to pull the "tabs from last time" data here:
http://mxr.mozilla.org/mobile-browser/source/components/SessionStore.js#89

This is called from an event handler for "final-ui-startup" here:
http://mxr.mozilla.org/mobile-browser/source/components/SessionStore.js#117

If Fennec wasn't actually closed, but only hidden, then this would possibly happen.

But I seriously doubt this is the problem. We should be updating the backup file in the background anyway. That would at least change the list of "tabs".
Yeah I've definitely completely restarted Fennec a few times in the last day.

I took a look at the sessionstore.bak and sessionstore.js files and the bak file shows the tab that it told me was last used. After restarting it correctly changed back to showing no tabs this time.

One thing that was odd though, both the js and bak files had modification times in the future, 8 hours in the future in fact. This sounds like a timezone oddity.
I just restarted Fennec using the notification in the Beta area and it failed to remember what tabs were open before
Blocks: 615287
Whiteboard: [fennec-sessionstore]
Sounds related to bug 630398. That's where I plan to fix it.
Status: NEW → RESOLVED
Closed: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 630398
You need to log in before you can comment on or make changes to this bug.