XULRunner 2.0 Windows builds won't launch as Application package.

RESOLVED FIXED

Status

Toolkit Graveyard
XULRunner
--
critical
RESOLVED FIXED
8 years ago
2 years ago

People

(Reporter: Ben Longoria, Unassigned)

Tracking

Details

(URL)

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10_6_4; en-us) AppleWebKit/533.17.8 (KHTML, like Gecko) Version/5.0.1 Safari/533.17.8
Build Identifier: xulrunner-2.0b8pre.en-US.win32.zip

Following the directions outlined on DMO <https://developer.mozilla.org/en/XULRunner/Deploying_XULRunner_1.8>, a properly configured application directory using XULRunner 2.0 won't launch under Windows XP.

I have also tried the configuration putting the chrome.manifest file at the root level.


Reproducible: Always

Steps to Reproduce:
1. Download "Hello World" XULRunner application at URL specified in this report
2. Unzip and launch WinXR20.exe on Windows XP
Actual Results:  
The app crashes and displays the following error message:

WinXR20.exe - Unable To Locate Component
This application has failed to start because MOZCRT19.dll was not found. Re-installing the application may fix this problem.

Expected Results:  
Launch and display a window with the text "Hello World"
(Reporter)

Updated

8 years ago
blocking2.0: --- → ?

Updated

8 years ago
blocking2.0: ? → -
(Reporter)

Comment 1

8 years ago
With help from IRC, found two important steps to get this to work.
I have updated the documentatoin on DMO with two notes.

https://developer.mozilla.org/en/XULRunner/Deploying_XULRunner_1.8
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → FIXED
(Assignee)

Updated

2 years ago
Product: Toolkit → Toolkit Graveyard
You need to log in before you can comment on or make changes to this bug.