Closed Bug 605253 Opened 9 years ago Closed 9 years ago

beta feedback form unusable on Samsung Vibrant Android phone in vertical orientation

Categories

(Firefox for Android Graveyard :: Panning/Zooming, defect)

x86
Linux
defect
Not set

Tracking

(fennec2.0b2+)

VERIFIED FIXED
Tracking Status
fennec 2.0b2+ ---

People

(Reporter: myk, Assigned: vingtetun)

Details

Attachments

(1 file)

It isn't possible to use the beta feedback form at Gear Icon > Beta Tester Tools > Communicate to Us! > :-)/( with my Samsung Vibrant Android phone in the vertical orientation, because the moment I focus the text field in it, Fennec zooms in on the field to such an extent that most of the field is hidden offscreen, and after typing a few characters on the virtual keyboard, the cursor moves offscreen, and I stop being able to see what I am typing.

I can pan manually to show the cursor again by dragging my finger across the screen, but then the virtual keyboard goes away (even though the text field appears to remain focused, as it still contains the cursor).  If I then tap in the field to bring the keyboard back, Fennec pans back to the beginning of the field, hiding the cursor again.

Either Fennec shouldn't hide part of the field offscreen, or it should pan across the field automatically as I type to keep the cursor onscreen, or the virtual keyboard shouldn't go away when I pan manually, or Fennec shouldn't pan back to the beginning of the field when I tap in the field to bring the keyboard back, or more than one of those things should happen.

Note: the workaround is to switch to horizontal orientation, which invokes a different input mode that doesn't have this problem.

Note: potentially related bugs are bug 524978, bug 598234, and bug 599419, although those are all verified fixed.
hi myk, any chance you can include a screenshot?   Do you get something like bug 604242, but with the text box for the feedback site?
(In reply to comment #1)
> hi myk, any chance you can include a screenshot?   Do you get something like
> bug 604242, but with the text box for the feedback site?

I see that problem as well on some sites, but this is a different problem.  A screenshot doesn't quite capture it, but here's a video that shows the problem:

  https://people.mozilla.com/~myk/bug-605253.mov
We should be panning to the end of the input field. I think this might relate to the viewport width and the form assistant as the intended behavior works fine on bugzilla's advanced search form.
tracking-fennec: --- → ?
Assignee: nobody → 21
tracking-fennec: ? → 2.0b3+
The bug should be mostly fix now with some changes to how the Form Assitant handle fields. You should see the whole field, in the other case the view should pan automatically when the typed character goes offscreen.

There is still the VKB that should not go away when you pan the view (patch coming)
Comment on attachment 486463 [details] [diff] [review]
Patch - do not dismiss the VKB while panning/zooming

Should be fine since we don't count on the browser ever getting focus by user input, IIRC.

Matt - Seem ok to you?

We should land this for b2
Attachment #486463 - Flags: review?(mbrubeck)
Attachment #486463 - Flags: review?(mark.finkle)
Attachment #486463 - Flags: review+
tracking-fennec: 2.0b3+ → 2.0b2+
Comment on attachment 486463 [details] [diff] [review]
Patch - do not dismiss the VKB while panning/zooming

Looks okay to me.  I did some simple tests on a local build and could not find any problems with hardware or software keyboard focus.
Attachment #486463 - Flags: review?(mbrubeck) → review+
http://hg.mozilla.org/mobile-browser/rev/ce7b7ba6ca1b
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → FIXED
verified FIXED on build:

Mozilla/5.0 (Android; Linux armv71; rv:2.0b8pre) Gecko/20101028 Namoroka/4.0b8pre Fennec/4.0b2pre
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.