Enabling hardware acceleration with Nvidia Optimus causes flickering

RESOLVED WORKSFORME

Status

()

RESOLVED WORKSFORME
8 years ago
3 years ago

People

(Reporter: smoohta, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b8pre) Gecko/20101018 Firefox/4.0b8pre
Build Identifier: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b8pre) Gecko/20101018 Firefox/4.0b8pre

My new Asus U35JC laptop is equipped with Nvidia Optimus.
Whenever I open the Firefox nightly the window flickers horribly ("normal window" flickers with alternating "black parts"), when I disable hardware acceleration the flickering stops.
If I force Firefox (via the Nvidia control panel) to only use the Intel GPU (instead of the default preset of automatically deciding) no flickering occurs but if I set it to use the Nvidia GPU the awful flickering occurs.

Here is the about:support info when flickering occurs:

  Graphics

        Adapter Description
        Intel(R) HD Graphics

        Vendor ID
        8086

        Device ID
        0046

        Adapter RAM
        Unknown

        Adapter Drivers
        igdumd64 igd10umd64 igdumdx32 igd10umd32

        Driver Version
        8.15.10.2202

        Driver Date
        8-25-2010

        Direct2D Enabled
        true

        DirectWrite Enabled
        true

      GPU Accelerated Windows
      0/2

Setting layers.use-d3d10 to true also seems to fix the flickering, here is the about:support output when it's on:

  Graphics

        Adapter Description
        Intel(R) HD Graphics

        Vendor ID
        8086

        Device ID
        0046

        Adapter RAM
        Unknown

        Adapter Drivers
        igdumd64 igd10umd64 igdumdx32 igd10umd32

        Driver Version
        8.15.10.2202

        Driver Date
        8-25-2010

        Direct2D Enabled
        true

        DirectWrite Enabled
        true

      GPU Accelerated Windows
      1/1 Direct3D 10

Note: when Hardware acceleration is on the Nvidia GPU is on all the time, which I'm not sure is what should happen (since it'll drain battery life significantly vs only running Intel GPU) with Optimus - I suppose giving the user an option to choose which GPU to run on is best but that may be a much bigger fish to fry.

Another note: Bug 597303 also seems to be about the same issue and it's marked as fixed (since bug 597320 was suspected as the cause of the problem but evidently it's not)- I've posted a comment there but more than a week has passed and no one has replied (is there a way for me to re-open that bug?) so I've opened this bug as well, feel free to mark this as a duplicate of that one if you want :)

Reproducible: Always

Steps to Reproduce:
1. Open Firefox nightly with hardware acceleration on
2. See the window flicker
3. Change layers.use-d3d10 to true, restart Firefox
4. No flickering occurs
5. set Hardware acceleration off, restart Firefox
6. No flickering occurs
D3D10 layers will be default. Other modes should be disabled going forward, that will be the main solution for this bug.
(Reporter)

Comment 2

8 years ago
D3D10 layers has landed right? the current nightly with acceleration by default doesn't have any of the flickering I reported earlier

Comment 3

8 years ago
Windows 7 x86_64 with Minefield i686-pc-mingw32 674f2ed15cea. 
I can confirm the flickering is now gone with Nvidia Optimus (Intel HD Graphics with Nvidia Geforce 330M 260.99). Whereas in a previous beta I had massive flickering when Firefox was configured to use the Nvidia GPU

Comment 4

8 years ago
Brand new optimus enabled dell xps15, fresh firefox installs -

In firefox 3.x I got this flickering on youtube video control overlays in fullscreen mode only.

In firefox 4 x86 nightlights I get pitchblack for fullscreen, no video at all.

disable flash hw acceleration the problems go away, but quality is reduced.

Comment 5

8 years ago
More info for the above -
Intel HD driver 8.15.10.2266
dell supplied Nvidia driver version 259.51 (generic nv mobile drivers refuse to install)

latest final flash build. (the flash 10.2 beta locks up minefield x86 when fullscreening youtube content and completely refuses forced termination)

win7 x64.

Comment 6

3 years ago
(In reply to Barak Gross from comment #2)
> D3D10 layers has landed right? the current nightly with acceleration by
> default doesn't have any of the flickering I reported earlier

WFM
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.