need for a filter method to catch png viagra spam

RESOLVED DUPLICATE of bug 280716

Status

Thunderbird
General
--
enhancement
RESOLVED DUPLICATE of bug 280716
8 years ago
8 years ago

People

(Reporter: ffux, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-GB; rv:1.9.2) Gecko/20100212 Gentoo
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.2.4) Gecko/20100630 Lanikai/3.1

Existing filter definition mechanism limitted to lexical "contains" "starts with" type filters. More flexibility may be needed to counter evolving spammer techniques.


Reproducible: Always

Steps to Reproduce:
1.recv spam where sole content is multipart/mixed , no text , just one png viagre spam image for up25.ru type pill pushers address.
2.Try to construct filter to match.
3.
Actual Results:  
Using customise headers is good and allows matching of X-Mozilla-Status2 to detect an attachment and Content-Type: multipart/mixed. But this is still too general.

Expected Results:  
More flexible filter setting to enable targeting more precise filters.

These guys will always come up with new tricks but at least we need the flexibility to adapt as well. 

Ideas :
a means to detect image without body text

a means to do arithmetical or logical tests:(X-Mozilla-Status2 < 1000000)  (X-Mozilla-Status2 AND 1000000) as well as lexical "begins with" "ends with" "contains" etc.

a filter on attachment size.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 280716
You need to log in before you can comment on or make changes to this bug.