If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Crash occurred when trying to turn on error console and restarting [@ linux-gate.so@0x422 ]

RESOLVED WORKSFORME

Status

()

Core
Widget: Gtk
--
critical
RESOLVED WORKSFORME
7 years ago
4 years ago

People

(Reporter: nhirata, Unassigned)

Tracking

({crash})

1.9.2 Branch
x86
Linux
crash
Points:
---

Firefox Tracking Flags

(fennec-)

Details

(crash signature)

Mozilla/5.0 (X11; Linux i686; rv:2.0b8pre) Gecko/20101018 Firefox/4.0b8pre Fennec/4.0b2pre

http://crash-stats.mozilla.com/report/index/04515790-2294-447a-9ecb-56b3b2101018

Note: not 100 % sure of steps:
1. go to http://rss.cnn.com/rss/cnn_topstories.rss
2. while it's loading go to control panel
3. go to feedback
4. turn feedback on
5. restart fennec

Expected: no crash
Actual : crash

Crash log :
Crashing Thread
Frame 	Module 	Signature [Expand] 	Source
0 	linux-gate.so 	linux-gate.so@0x422 	
1 	libc-2.11.1.so 	libc-2.11.1.so@0x2da81 	
2 	libmozalloc.so 	mozalloc_abort 	memory/mozalloc/mozalloc_abort.cpp:75
3 	libxul.so 	NS_DebugBreak_P 	xpcom/base/nsDebugImpl.cpp:379
4 	libxul.so 	X11Error 	toolkit/xre/nsX11ErrorHandler.cpp:190
5 	libbonoboui-2.so.0.0.0 	libbonoboui-2.so.0.0.0@0x20d33 	
6 	libX11.so.6.3.0 	libX11.so.6.3.0@0x3b298 	
7 	libX11.so.6.3.0 	libX11.so.6.3.0@0x4192e 	
8 	libX11.so.6.3.0 	libX11.so.6.3.0@0x42355 	
9 	libX11.so.6.3.0 	libX11.so.6.3.0@0x2aa67 	
10 	libgdk-x11-2.0.so.0.2000.1 	libgdk-x11-2.0.so.0.2000.1@0x53977 	
11 	libglib-2.0.so.0.2400.1 	libglib-2.0.so.0.2400.1@0x3eac9 	
12 	libglib-2.0.so.0.2400.1 	libglib-2.0.so.0.2400.1@0x3eee8 	
13 	libglib-2.0.so.0.2400.1 	libglib-2.0.so.0.2400.1@0x3f4b7 	
14 	libxul.so 	nsAppShell::ProcessNextNativeEvent 	widget/src/gtk2/nsAppShell.cpp:144
15 	libxul.so 	nsBaseAppShell::DoProcessNextNativeEvent 	widget/src/xpwidgets/nsBaseAppShell.cpp:161
16 	libxul.so 	nsBaseAppShell::OnProcessNextEvent 	widget/src/xpwidgets/nsBaseAppShell.cpp:305
17 	libxul.so 	nsThread::ProcessNextEvent 	xpcom/threads/nsThread.cpp:517
18 	libxul.so 	NS_ProcessPendingEvents_P 	nsThreadUtils.cpp:200
19 	libxul.so 	mozilla::ShutdownXPCOM 	xpcom/build/nsXPComInit.cpp:628
20 	libxul.so 	ScopedXPCOMStartup::~ScopedXPCOMStartup 	toolkit/xre/nsAppRunner.cpp:1117
21 	libxul.so 	XRE_main 	toolkit/xre/nsAppRunner.cpp:3700
22 	fennec 	main 	mobile/app/nsBrowserApp.cpp:155
23 	libc-2.11.1.so 	libc-2.11.1.so@0x16bd5 	
24 	fennec 	fennec@0x12d0 	
25 	fennec 	Output 	mobile/app/nsBrowserApp.cpp:77
26 		@0x0
Keywords: crash
Simplier steps:  
1) turn on feedback
2) quit fennec

It appear that having feedback turned on and quitting will cause fennec to crash.
Possibly a dup of Bug 605243 ?
(In reply to comment #1)
> Simplier steps:  
> 1) turn on feedback
> 2) quit fennec
> 
> It appear that having feedback turned on and quitting will cause fennec to
> crash.
> Possibly a dup of Bug 605243 ?

Are you able to start Fennec back up after having enabled the error console? If it crashes than yeah mine is a dupe. In any case, this sounds the same.
Yes, I am able to start Fennec back up and web browse after crashing on quit.
Severity: normal → major

Comment 4

7 years ago
reporter: please run w/ --sync

Note that linux-gate.so is a totally useless stack frame for signatures, it's basically "kernel call", in this case it's the kernel call for "please kill me now"
Severity: major → critical
Keywords: stackwanted
After I ran from commandline (./fennec --sync), it did not crash on me.

I tried also running from UI afterwards and can no longer crash.  I am guessing that it maybe some sort of initialization issue prior to running --sync?

Comment 6

7 years ago
--sync is an x11 protocol thing.

x11 is normally asynchronous, you make a request, you make another request, you make another request, eventually you get an answer for your first request.

--sync causes the process to wait for the answer to each request before it makes another.

The hope in general is that code is so buggy that you can find its bug w/ --sync and it's obvious. In other cases, um....

Comment 7

7 years ago
you could try http://xmsgtrace.sourceforge.net/ or some other x11 protocol logger...
I did crash again on today's build.  I needed a step of going to a remote site ( ie 
1) launch
2) go to http://www.cnn.com/help/rss.html
3) go to feedback
4) turn on error console, restart.

http://crash-stats.mozilla.com/report/index/fb3c714d-60d7-4452-a568-bfb372101019

Crashing Thread
Frame 	Module 	Signature [Expand] 	Source
0 	linux-gate.so 	linux-gate.so@0x422 	
1 	libc-2.11.1.so 	libc-2.11.1.so@0x2da81 	
2 	libmozalloc.so 	mozalloc_abort 	memory/mozalloc/mozalloc_abort.cpp:75
3 	libxul.so 	NS_DebugBreak_P 	xpcom/base/nsDebugImpl.cpp:379
4 	libxul.so 	X11Error 	toolkit/xre/nsX11ErrorHandler.cpp:190
5 	libbonoboui-2.so.0.0.0 	libbonoboui-2.so.0.0.0@0x20d33 	
6 	libX11.so.6.3.0 	libX11.so.6.3.0@0x3b298 	
7 	libX11.so.6.3.0 	libX11.so.6.3.0@0x4192e 	
8 	libX11.so.6.3.0 	libX11.so.6.3.0@0x41fb5 	
9 	libX11.so.6.3.0 	libX11.so.6.3.0@0x35846 	
10 	libX11.so.6.3.0 	libX11.so.6.3.0@0x152cb 	
11 	libgdk-x11-2.0.so.0.2000.1 	libgdk-x11-2.0.so.0.2000.1@0x49139 	
12 	libgobject-2.0.so.0.2400.1 	libgobject-2.0.so.0.2400.1@0xd3f3 	
13 	libgdk-x11-2.0.so.0.2000.1 	libgdk-x11-2.0.so.0.2000.1@0x19427 	
14 	libxul.so 	MOZ_gdk_display_close 	toolkit/xre/nsAppRunner.cpp:2697
15 	libxul.so 	XRE_main 	toolkit/xre/nsAppRunner.cpp:3737
16 	fennec 	main 	mobile/app/nsBrowserApp.cpp:155
17 	libc-2.11.1.so 	libc-2.11.1.so@0x16bd5 	
18 	fennec 	fennec@0x12d0 	
19 	fennec 	Output 	mobile/app/nsBrowserApp.cpp:77
20 		@0x0 	

I haven't tried with the xmsgtrace.sourceforge.net yet.

Comment 9

7 years ago
is this with or without --sync? if it's without it's a waste of my time. if it's with, it's vaguely useful.
note that there should be output in your terminal for such failures (if you choose to use one).

I believe we have bugs for an error in MOZ_gdk_display_close...

X_FreePixmap: BadPixmap (invalid Pixmap parameter); 48 requests ago
OS: Linux → Windows CE

Updated

7 years ago
OS: Windows CE → Linux
It was with --sync.

mozilla@ubuntu:~/Desktop/fennec$ ./fennec --sync
###################################### forms.js loaded
###################################### content loaded
!! remote browser loaded
creating 1!
[TabChild] SHOW (w,h)= (0, 0)
###################################### forms.js loaded
###################################### content loaded
!! remote browser loaded
loading about:blank, 1
[TabChild] RESIZE to (w,h)= (800d, 500d)
NOTE: child process received `Goodbye', closing down
###################################### forms.js loaded
###################################### content loaded
!! remote browser loaded
creating 1!
[TabChild] SHOW (w,h)= (0, 0)
###################################### forms.js loaded
###################################### content loaded
!! remote browser loaded
loading about:blank, 1
[TabChild] RESIZE to (w,h)= (800d, 500d)
NOTE: child process received `Goodbye', closing down
###!!! ABORT: X_FreePixmap: BadPixmap (invalid Pixmap parameter); 49 requests ago: file /builds/slave/linux-fennec-trunk-nightly/build/mozilla-central/toolkit/xre/nsX11ErrorHandler.cpp, line 190
###!!! ABORT: X_FreePixmap: BadPixmap (invalid Pixmap parameter); 49 requests ago: file /builds/slave/linux-fennec-trunk-nightly/build/mozilla-central/toolkit/xre/nsX11ErrorHandler.cpp, line 190
tracking-fennec: --- → ?
Naoki, here's a list of bugs this is related to: 


https://bugzilla.mozilla.org/buglist.cgi?query_format=advanced&bug_status=UNCONFIRMED&bug_status=NEW&bug_status=ASSIGNED&bug_status=REOPENED&longdesc=MOZ_gdk_display_close&longdesc_type=allwordssubstr

Updated

7 years ago
Assignee: nobody → azakai
tracking-fennec: ? → 2.0+
Correction: I didn't mean feedback in comment 0, comment 1 ; I meant the error console.
I get this in the nightly build, but not in a build from right now that I made myself.

crashreporter was suspected, but I still don't get the crash even with it enabled in my build.
Don't see this in either gtk or qt builds.
What if you build with the official nightly mozconfig?
Cannot reproduce this when building with the official nightly mozconfig,

  mk_add_options MOZ_OBJDIR=../fennec
  mk_add_options MOZ_PKG_FORMAT=BZ2
  ac_add_options --disable-javaxpcom
  ac_add_options --enable-application=mobile
  ac_add_options --enable-debug-symbols="-gdwarf-2"
  export MOZILLA_OFFICIAL=1

Is anyone still seeing this issue?
Cannot reproduce this on latest nightly build.
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → WORKSFORME
http://crash-stats.mozilla.com/report/index/f6f145ea-56be-442f-abba-cb5522101029

Related Bugs:
OPEN        559704 NEW crash [@ linux-gate.so@0x422]
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---
Naoki, if you can reproduce it, that stack shows that you should be seeing an error message in the console.
Cannot reproduce this on latest nightly.

If other people still see this, perhaps it is graphics driver related? For comparison, I am on a macbook pro, with nvidia binary drivers.
(In reply to comment #19)
> Naoki, if you can reproduce it, that stack shows that you should be seeing an
> error message in the console.

Mozilla/5.0 (X11; Linux i686; rv:2.0b8pre) Gecko/20101102 Firefox/4.0b8pre Fennec/4.0b3pre

http://crash-stats.mozilla.com/report/index/bp-2b59915d-e380-4073-9851-3a2b22101102

mozilla@ubuntu:~/Desktop/fennec_11022010$ ./fennec --sync
###################################### forms.js loaded
###################################### content loaded
!! remote browser loaded
creating 1!
[TabChild] SHOW (w,h)= (0, 0)
###################################### forms.js loaded
###################################### content loaded
!! remote browser loaded
loading about:blank, 1
[TabChild] RESIZE to (w,h)= (800d, 500d)
NOTE: child process received `Goodbye', closing down
###################################### forms.js loaded
###################################### content loaded
!! remote browser loaded
creating 1!
[TabChild] SHOW (w,h)= (0, 0)
###################################### forms.js loaded
###################################### content loaded
!! remote browser loaded
loading about:blank, 1
[TabChild] RESIZE to (w,h)= (800d, 500d)
NOTE: child process received `Goodbye', closing down
###!!! ABORT: X_FreePixmap: BadPixmap (invalid Pixmap parameter); 149 requests ago: file /builds/slave/places-mobile-browser-linux-nightly/build/places/toolkit/xre/nsX11ErrorHandler.cpp, line 190
###!!! ABORT: X_FreePixmap: BadPixmap (invalid Pixmap parameter); 149 requests ago: file /builds/slave/places-mobile-browser-linux-nightly/build/places/toolkit/xre/nsX11ErrorHandler.cpp, line 190
mozilla@ubuntu:~/Desktop/fennec_11022010$ ###################################### forms.js loaded
###################################### content loaded
!! remote browser loaded
^C
mozilla@ubuntu:~/Desktop/fennec_11022010$ 


Crashing Thread
Frame 	Module 	Signature [Expand] 	Source
0 	linux-gate.so 	linux-gate.so@0x422 	
1 	libc-2.11.1.so 	libc-2.11.1.so@0x2da81 	
2 	libmozalloc.so 	mozalloc_abort 	memory/mozalloc/mozalloc_abort.cpp:75
3 	libxul.so 	NS_DebugBreak_P 	xpcom/base/nsDebugImpl.cpp:379
4 	libxul.so 	X11Error 	toolkit/xre/nsX11ErrorHandler.cpp:190
5 	libbonoboui-2.so.0.0.0 	libbonoboui-2.so.0.0.0@0x20d33 	
6 	libX11.so.6.3.0 	libX11.so.6.3.0@0x3b298 	
7 	libX11.so.6.3.0 	libX11.so.6.3.0@0x4192e 	
8 	libX11.so.6.3.0 	libX11.so.6.3.0@0x41fb5 	
9 	libX11.so.6.3.0 	libX11.so.6.3.0@0x35846 	
10 	libX11.so.6.3.0 	libX11.so.6.3.0@0x152cb 	
11 	libgdk-x11-2.0.so.0.2000.1 	libgdk-x11-2.0.so.0.2000.1@0x49139 	
12 	libgobject-2.0.so.0.2400.1 	libgobject-2.0.so.0.2400.1@0xd3f3 	
13 	libgdk-x11-2.0.so.0.2000.1 	libgdk-x11-2.0.so.0.2000.1@0x19427 	
14 	libxul.so 	MOZ_gdk_display_close 	toolkit/xre/nsAppRunner.cpp:2697
15 	libxul.so 	XRE_main 	toolkit/xre/nsAppRunner.cpp:3749
16 	fennec 	main 	mobile/app/nsBrowserApp.cpp:155
17 	libc-2.11.1.so 	libc-2.11.1.so@0x16bd5 	
18 	fennec 	fennec@0x12d0 	
19 	fennec 	Output 	mobile/app/nsBrowserApp.cpp:77
20 		@0x0

Updated

7 years ago
Assignee: azakai → nobody
Component: General → Widget: Gtk
Product: Fennec → Core
QA Contact: general → gtk
Whiteboard: DUPEME
Version: Trunk → 1.9.2 Branch
Keywords: stackwanted

Updated

7 years ago
tracking-fennec: 2.0+ → 2.0-
Status: REOPENED → RESOLVED
Last Resolved: 7 years ago7 years ago
Resolution: --- → WORKSFORME
(Assignee)

Updated

6 years ago
Crash Signature: [@ linux-gate.so@0x422 ]

Updated

4 years ago
Whiteboard: DUPEME
You need to log in before you can comment on or make changes to this bug.