"ASSERTION: Can't find flow containing this frame???"

RESOLVED FIXED in mozilla2.0b7

Status

()

Core
Layout
--
critical
RESOLVED FIXED
7 years ago
7 years ago

People

(Reporter: Jesse Ruderman, Assigned: Mats Palmgren (vacation - back in August))

Tracking

(Blocks: 2 bugs, 4 keywords)

Trunk
mozilla2.0b7
assertion, crash, regression, testcase
Points:
---
Dependency tree / graph
Bug Flags:
in-testsuite +

Firefox Tracking Flags

(blocking1.9.2 .13+, status1.9.2 .13-fixed, blocking1.9.1 .16+, status1.9.1 .16-fixed)

Details

Attachments

(4 attachments)

(Reporter)

Description

7 years ago
Created attachment 484178 [details]
testcase

###!!! ASSERTION: Can't find flow containing this frame???: 'Error', file layout/generic/nsTextFrameThebes.cpp, line 2158
(Reporter)

Comment 1

7 years ago
Created attachment 484180 [details]
stack trace
Assignee: nobody → matspal
Severity: normal → critical
Keywords: crash, regression
OS: Mac OS X → All
Hardware: x86 → All
Created attachment 484276 [details] [diff] [review]
crashtest.diff
Created attachment 484280 [details] [diff] [review]
Patch rev. 1

Silly mistake - 'mLastFlowIndex' became out-of-bounds.
As I understand it, 'mLastFlowIndex' is just an optimization used
as a hint when mapping content -> mapped flow, so any valid index
is correct.  The last index seems like a good choice.

With this patch the testcase still asserts but those will be fixed
in bug 604843.  This patch is independent of that bug though.

I'm adding "[run=0xNNNNNNNN]" to the text frame dump since I often
find it useful when debugging.
Attachment #484280 - Flags: review?(roc)
Attachment #484280 - Flags: approval2.0?
Blocks: 571995
Depends on: 604843
Comment on attachment 484280 [details] [diff] [review]
Patch rev. 1

Test?
Attachment #484280 - Flags: review?(roc)
Attachment #484280 - Flags: review+
Attachment #484280 - Flags: approval2.0?
Attachment #484280 - Flags: approval2.0+
http://hg.mozilla.org/mozilla-central/rev/fe4243e45cf1
http://hg.mozilla.org/mozilla-central/rev/898db83dc637
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Flags: in-testsuite+
Resolution: --- → FIXED
Target Milestone: --- → mozilla2.0b8
Target Milestone: mozilla2.0b8 → mozilla2.0b7
Marking this regression a branch blocker for qa verification because bug 571995 is a blocker.
blocking1.9.1: --- → .16+
blocking1.9.2: --- → .13+
status1.9.1: --- → wanted
status1.9.2: --- → wanted
http://hg.mozilla.org/releases/mozilla-1.9.1/rev/650e7b0d6d34
http://hg.mozilla.org/releases/mozilla-1.9.1/rev/bd03fbc2b2fc
http://hg.mozilla.org/releases/mozilla-1.9.1/rev/19e3f097936a
http://hg.mozilla.org/releases/mozilla-1.9.1/rev/91bf1ee0a8ac
http://hg.mozilla.org/releases/mozilla-1.9.1/rev/5cb35072f373
http://hg.mozilla.org/releases/mozilla-1.9.1/rev/6444dcb39b02

http://hg.mozilla.org/releases/mozilla-1.9.2/rev/64e803656a1f
http://hg.mozilla.org/releases/mozilla-1.9.2/rev/ee365bf30311
http://hg.mozilla.org/releases/mozilla-1.9.2/rev/0ac503e14b53
http://hg.mozilla.org/releases/mozilla-1.9.2/rev/1d2fa8e53cc3
http://hg.mozilla.org/releases/mozilla-1.9.2/rev/57ce1356af46
http://hg.mozilla.org/releases/mozilla-1.9.2/rev/3956db8d0373
status1.9.1: wanted → .16-fixed
status1.9.2: wanted → .13-fixed
You need to log in before you can comment on or make changes to this bug.