https links open Konqueror instead of Firefox

UNCONFIRMED
Unassigned

Status

Thunderbird
Preferences
UNCONFIRMED
7 years ago
2 years ago

People

(Reporter: markusd112, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

7 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; de; rv:1.9.2.10) Gecko/20100922 Ubuntu/10.10 (maverick) Firefox/3.6.10
Build Identifier: Thunderbird 3.1.6

When I receive a mail with a http link in it, Firefox is opened when I click on the link. But if there is a https link inside the mail, Thunderbird does not start Firefox, but Konqueror. But I don't want to start Konqueror, TB should start FF.

Reproducible: Always

Steps to Reproduce:
1. click on a https link
Actual Results:  
TB starts Konqueror

Expected Results:  
TB should start Firefox

I have tried to use a completely new profile, but the same problem exists there too. In the Gnome menu (System --> Preferred Applications) I have selected Firefox as default browser.
(In reply to comment #0)

> too. In the Gnome menu (System --> Preferred Applications) I have selected
> Firefox as default browser.

Is that an alias to gconf2 ?
(Reporter)

Comment 2

7 years ago
No, it starts "gnome-default-applications-properties"...
(Reporter)

Comment 3

7 years ago
In the ubuntu bugtracker I have got this solution that worked for me:

sudo update-alternatives --verbose --config x-www-browser

Comment 4

6 years ago
ludo, thoughts?

Comment 5

6 years ago
I think this will be solved when we (Ubuntu) jump to rapid release.  Most browsers install themselves with a higher alternative priority than Firefox making them the default x-www-browser, but not the default system browser.  I think Thunderbird was changed post 3.1 to use xdg-open instead of using the alternative which should fix the issue.  We're migrating Lucid (10.04) and Natty (11.04) to Thunderbird 11 some time around April 10.  As Maverick (10.10) is EOL then, it will not be receiving this update.  In the mean time, if you can test the latest Thunderbird stable release to see if this is still an issue, that would be great: https://launchpad.net/~mozillateam/+archive/thunderbird-stable
You need to log in before you can comment on or make changes to this bug.