Addons Manager "More" button has unexpected results.

RESOLVED DUPLICATE of bug 608468

Status

()

defect
RESOLVED DUPLICATE of bug 608468
9 years ago
9 years ago

People

(Reporter: pjdkrunkt, Unassigned)

Tracking

Trunk
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Reporter

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows NT 5.1; rv:2.0b8pre) Gecko/20101018 Firefox/4.0b8pre
Build Identifier: Mozilla/5.0 (Windows NT 5.1; rv:2.0b8pre) Gecko/20101018 Firefox/4.0b8pre

In the main list item for each addon, a few words from the Description section of the install.rdf are shown followed by ... More.  A user would expect that by clicking the "More" button they would be shown the rest of that Description. (which they could previously read all of in older versions of Firefox by simply clicking anywhere on the list item).  Instead, they are shown a completely different set of text in the details panel extracted from addons.mozilla.org "More about this add-on".

Not only is this unexpected, but the user will never be able to read the entire short description!  

Suggestions:

A. Expand the short description when the background of list item is clicked on as in previous versions of Firefox.  This option would be nice because it provides a little bit of familiarity in an otherwise quite foreign interface.

or

B. Show the short description instead of the "More about this add-on" description in the details panel.  The format of the details panel in general makes it appear like it should be close to a copy of the top boxed-in section of the AMO page. In that layout the short install.RDF description is what is shown in that position.  It should also be noted that the "More about..." section of the AMO page is used for all kinds of different things by different authors and may include information and links that are not really pertinent after it is installed, and in some cases can be quite long.

If the "More about..." information is kept then there needs to be scrollbar in that window to facilitate navigation of long articles, and the preview image should probably be aligned to the top instead of the bottom.



Reproducible: Always
Reporter

Comment 1

9 years ago
Long "More about..." comments seem to be more common with Themes, probably because Theme authors are less likely to host a special support website than Extension authors, and because options within Themes require more explanation because of the lack of an Options panel:

https://addons.mozilla.org/en-US/firefox/addon/3699/
https://addons.mozilla.org/en-US/firefox/addon/4908/
https://addons.mozilla.org/en-US/firefox/addon/11861/

Updated

9 years ago
Status: UNCONFIRMED → NEW
Component: General → Add-ons Manager
Ever confirmed: true
Product: Firefox → Toolkit
QA Contact: general → add-ons.manager
Version: unspecified → Trunk
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 608468
You need to log in before you can comment on or make changes to this bug.