If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Web console logging throws an error if you reopen the console

RESOLVED WORKSFORME

Status

()

Firefox
Developer Tools
--
major
RESOLVED WORKSFORME
7 years ago
7 years ago

People

(Reporter: Laxminarayan G Kamath A, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

7 years ago
User-Agent:       Mozilla/5.0 (X11; Linux i686; rv:2.0b8pre) Gecko/20101019 Firefox/4.0b8pre
Build Identifier: Mozilla/5.0 (X11; Linux i686; rv:2.0b8pre) Gecko/20101019 Firefox/4.0b8pre

I opened up web console, did somethng and closed it. a couple of seconds later, opened it again and it came up with this message 

"20:26:46.438: The Web Console logging API (console.log, console.info, console.warn, console.error) has been disabled by a script on this page."

Reproducible: Always

Steps to Reproduce:
1.open a web page
2. fire up web console (ctrl-shift-k)
3. close web console (ctrl-shift-k)
4. fire up web console again  (ctrl-shift-k) . Make sure you don't reload the page you are on.
Actual Results:  
you are presented with the message "The Web Console logging API (console.log, console.info, console.warn, console.error) has been disabled by a script on this page."

Expected Results:  
It shouldn't. and should have all panels enabled.

happens if you dont reload the page.
blocking2.0: --- → ?
Component: General → Developer Tools
Product: Core → Firefox
QA Contact: general → developer.tools

Comment 1

7 years ago
i'm seeing this too:

08:05:25.790: [Exception... "Component returned failure code: 0x80004005 (NS_ERROR_FAILURE) [nsIScrollBoxObject.ensureElementIsVisible]"  nsresult: "0x80004005 (NS_ERROR_FAILURE)"  location: "JS frame :: resource:///modules/HUDService.jsm :: ConsoleUtils_scrollToVisible :: line 4991"  data: no]
Status: UNCONFIRMED → NEW
Ever confirmed: true

Updated

7 years ago
Summary: Web console gets disabled if you close it and open it again in any page(if you dont reload) → Web console logging throws an error if you reopen the console

Updated

7 years ago
Blocks: 593957
(Reporter)

Comment 2

7 years ago
Ha.. a wild guess from a non-mozilla-developer. 
1) A new log element is created  of type network.
2) As a new log element is created, it tries to scroll down by making that new element visible.
3) somehow , its forgetting to check the type and if the element is really added to the list(?) because of filtering.
I believe this'll be fixed by the "lazy console" bug. Adding it as a blocking bug.
Blocks: 594225, 587734
No longer blocks: 593957
Can't reproduce on trunk. Fixed by the lazy console?

Comment 5

7 years ago
Agreed, WFM.

Comment 6

7 years ago
(In reply to comment #4)
> Can't reproduce on trunk. Fixed by the lazy console?

yep.

fixed by bug 587734
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → WORKSFORME
blocking2.0: ? → ---
You need to log in before you can comment on or make changes to this bug.