Obtain symbols for nvidia drivers

RESOLVED WONTFIX

Status

()

Core
Graphics
RESOLVED WONTFIX
8 years ago
8 years ago

People

(Reporter: jrmuizel, Assigned: kev)

Tracking

unspecified
x86
Windows 7
Points:
---

Firefox Tracking Flags

(blocking2.0 -)

Details

(Reporter)

Description

8 years ago
In order to make it easier to triage crashes we're seeing in the user mode drivers we'll need symbols so that we have a decent crash signatures to work with.
If they need to be, the symbols can be obfuscated like we have for flash.
(Reporter)

Comment 1

8 years ago
Bas, can you connect Benjamin (or someone else, if there's a better person) with somebody at nvidia that can help us move this forward.
Assignee: nobody → bas.schouten
(Reporter)

Updated

8 years ago
blocking2.0: --- → ?

Comment 2

8 years ago
I really don't have time to spend with nvidia directly, but all we need are the PDB files, and Ted or I can generate .sym files and put them in locally.
(Reporter)

Comment 3

8 years ago
(In reply to comment #2)
> I really don't have time to spend with nvidia directly, but all we need are the
> PDB files, and Ted or I can generate .sym files and put them in locally.

What process do we have with Adobe for getting updated pdb files? Do they have a symbol server that we use?

Comment 4

8 years ago
Adobe emails the PDB files to Ted (and myself) and Ted converts/uploads them manually.
Kev, we could really use your help on this.
Assignee: bas.schouten → kev
blocking2.0: ? → betaN+
I did file bug 419879 some time ago, that's probably something we should pursue in the near future, since emailing symbols to me is not a highly automated setup.
(Assignee)

Comment 7

8 years ago
Seeing what I can do, here. Pinging a few folks.
Not going to happen; we've had this conversation before (and I thought folks here knew we had this conversation!).  We have ways of filing bugs to nvidia, and I blogged about how we can get them information they need to analyze them with minidumps -- Bas and I have access to file bugs in nvonline, and anyone else who needs it can get access as well.
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → INVALID
Totally disagree. We have no way of reproducing some of these, and further, we have no way of knowing whether we've got 3 or 3300 crashes without being able to get from nvogl32.dll@EFGHJIKL to something more unique.
Status: RESOLVED → REOPENED
Resolution: INVALID → ---
(Reporter)

Comment 10

8 years ago
(In reply to comment #8)
> Not going to happen; we've had this conversation before (and I thought folks
> here knew we had this conversation!).  We have ways of filing bugs to nvidia,
> and I blogged about how we can get them information they need to analyze them
> with minidumps -- Bas and I have access to file bugs in nvonline, and anyone
> else who needs it can get access as well.

I didn't know anything about that conversation. What were the reasons for not providing obfuscated symbols?
effort, basically -- they weren't willing to provide the actual symbols, and even providing obfuscated symbols would be tricky, as it would reveal the structure of the code.

Joe, not sure what you're disagreeing with -- this isn't exactly something that we can make happen on our end!  We've asked (a few times, email and in person), they've said no.

I absolutely agree that having this data would be useful, but more useful would be having them do the analysis and fix bugs.  Would be better if we tried to figure out a way to streamline the reporting process.

Comment 12

8 years ago
so is this bug wontfix?
(Assignee)

Comment 13

8 years ago
wontfix or invalid. what should probably be done, if it hasn't already, is to register as a dev and get access to their bug-filing system.
This depresses me to no end.
Status: REOPENED → RESOLVED
blocking2.0: betaN+ → -
Last Resolved: 8 years ago8 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.