non-standard attributes are removed when pasting into contentEditable editor

RESOLVED DUPLICATE of bug 596300

Status

()

Core
Editor
RESOLVED DUPLICATE of bug 596300
7 years ago
7 years ago

People

(Reporter: liucougar, Unassigned)

Tracking

1.9.2 Branch
x86_64
All
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

152 bytes, text/html
Details
(Reporter)

Description

7 years ago
open the attached file, click into the link, "ctrl+A" to select all in the contentEditable div, copy, click at the end of the content in the editor, and paste the content

the pasted <a> and <span> do not have any non-standard attributes any more

this is a regression from earlier FF
(Reporter)

Comment 1

7 years ago
Created attachment 484622 [details]
test case
Whiteboard: DUPEME
(Reporter)

Comment 2

7 years ago
more info: this is a regression introduced in 3.6.9 (present in 3.6.10 as well), while 3.6.8 works as expected

Comment 3

7 years ago
It should be noted that the special case of attributes starting with "_" has been fixed in bug 604332.
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Whiteboard: DUPEME
Duplicate of bug: 596300
You need to log in before you can comment on or make changes to this bug.