Closed Bug 605728 Opened 9 years ago Closed 7 years ago

Intermittent browser_focus_steal_from_chrome.js | Test timed out

Categories

(Core :: Layout: Form Controls, defect)

x86_64
All
defect
Not set

Tracking

()

RESOLVED WORKSFORME

People

(Reporter: philor, Unassigned)

References

Details

(Keywords: intermittent-failure)

http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1287550122.1287553361.32571.gz
Rev3 MacOSX Snow Leopard 10.6.2 mozilla-central debug test mochitest-other on 2010/10/19 21:48:42
s: talos-r3-snow-039

...
TEST-PASS | chrome://mochitests/content/browser/dom/tests/browser/browser_focus_steal_from_chrome.js | the foreground tab's INPUT element is not active by the focus of legend element (Test1: content can steal focus)
TEST-PASS | chrome://mochitests/content/browser/dom/tests/browser/browser_focus_steal_from_chrome.js | the INPUT element isn't focused by the focus of legend element (Test1: content can steal focus)
TEST-PASS | chrome://mochitests/content/browser/dom/tests/browser/browser_focus_steal_from_chrome.js | the background tab's INPUT element is not active by the focus of legend element (Test1: content can steal focus)
TEST-PASS | chrome://mochitests/content/browser/dom/tests/browser/browser_focus_steal_from_chrome.js | the INPUT element is focused by the focus of legend element (Test1: content can steal focus)
++DOMWINDOW == 164 (0x123bb1738) [serial = 3146] [outer = 0x11ca32000]
++DOMWINDOW == 165 (0x121524668) [serial = 3147] [outer = 0x125c191c0]
TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/dom/tests/browser/browser_focus_steal_from_chrome.js | Test timed out
INFO TEST-END | chrome://mochitests/content/browser/dom/tests/browser/browser_focus_steal_from_chrome.js | finished in 30259ms
TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/dom/tests/browser/browser_focus_steal_from_chrome.js | Found a tab after previous test timed out: data:text/html,<body%20onload="setTimeout(function%20()%20{%20document.getElementById('target').focus();%20},%2010);"><fieldset><legend%20id='target'>legend</legend><input></fieldset></body>
Duplicate of this bug: 605730
Windows appears to also be affected
OS: Mac OS X → All
Mass marking whiteboard:[orange] bugs WFM (to clean up TBPL bug suggestions) that:
* Haven't changed in > 6months
* Whose whiteboard contains none of the strings: {disabled,marked,random,fuzzy,todo,fails,failing,annotated,leave open,time-bomb}
* Passed a (quick) manual inspection of bug summary/whiteboard to ensure they weren't a false positive.

I've also gone through and searched for cases where the whiteboard wasn't labelled correctly after test disabling, by using attachment description & basic comment searches. However if the test for which this bug was about has in fact been disabled/annotated/..., please accept my apologies & reopen/mark the whiteboard appropriately so this doesn't get re-closed in the future (and please ping me via IRC or email so I can try to tweak the saved searches to avoid more edge cases).

Sorry for the spam! Filter on: #FFA500
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → WORKSFORME
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---
Whiteboard: [orange]
Resolving WFM keyword:intermittent-failure bugs last modified >3 months ago, whose whiteboard contains none of:
{random,disabled,marked,fuzzy,todo,fails,failing,annotated,time-bomb,leave open}

There will inevitably be some false positives; for that (and the bugspam) I apologise. Filter on orangewfm.
Status: REOPENED → RESOLVED
Closed: 7 years ago7 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.