When attempting to participate in the contest (which ends on Tuesday Nov 21st) Mozilla does not properly transfer to the Rules page after clicking the javascript "Enter The Game" button

VERIFIED WORKSFORME

Status

()

Core
JavaScript Engine
P3
minor
VERIFIED WORKSFORME
17 years ago
16 years ago

People

(Reporter: Matt Drew, Assigned: rogerl (gone))

Tracking

Trunk
x86
All
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.01; Windows 98)
BuildID:    2000101014

This could be an error on their part, but it worksforme with IE 5.01 SP1 on NT4 
SP6a, Netscape Communicator 4.72 on NT4 SP6a, Netscape Communicator 4.75 on Red 
Hat Linux 7, and IE5.01 SP1 on Win98 SP1.  This occurs in build 2000101014 on 
Win98 and in build 2000101015 on Red Hat Linux 7 (fully updated as of Nov 
16th).  The contest ends on Tuesday Nov 21st, so this is a bit time sensitive.

Basically what occurs is you click on the "Enter the Game" button to read the 
rules and submit your entry.  The status bar displays this address:

http://206.83.188.40/rules.html

Clicking the button removes the button from view (unclickable as well) and 
results in a "Document Done (0.05 seconds)" and a constantly spinning progress 
bar.  However, if you stop that attempt, and then refresh the page, the proper 
page comes up.  It is loading the page but not displaying it?  In addition, 
when the browser is in the "Document Done" state, the part of the page where 
the text should appear is not rendering at all -- a window placed over it 
results in screen corruption (the browser is not redrawing that portion of the 
page).

Reproducible: Always

Steps to Reproduce:
1.go to www.upn.com/upn.html
2.click on the "Freedom Contest Click Here" image map
3.on that "Win the Hottest Game" page, click the button that is flashing "Enter 
the Contest".
4.Mozilla M18 will go into the loop, and the central part of the page will stop 
being redrawn.
5.Click the "Stop" button to stop the attempt to load the page, then "Refresh".
6.Refreshing the page will bring up the proper page with the Rules and 
the "Accept"/"Decline" buttons at the bottom, and from there you can proceed 
normally to sell your soul for a PS2. :)

Actual Results:  Progress bar in the lower left corner runs right to left for 
at least five minutes.  Central area of the screen does not get redrawn at 
all.  It says "Document Done" in the status bar.  Upon Stopping the page load 
and hitting the Refresh button, the next page loads normally, and one can 
continue from there.

Expected Results:  Mozilla should have linked straight through to the next page.
Matt, I just tried it with linux build 2000-11-18-06 and it works perfectly.  I
don't see the problem you described. I am resolving this worksforme.  If you can
reproduce this with a recent nightly build (M18 is quite old and out of date at
this point), please reopen this bug.

Thanks for using Mozilla and reporting bugs!
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → WORKSFORME

Comment 2

17 years ago
Verifying WorksForMe. Using 20001105xx binaries on WinNT, Linux, and Mac.

Looks like the problem has been cleared up. Matt, thank you for such a 
well-written bug report! I wish they were all that good!
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.