GPLv2 license text in about:license is not consistent with the official GPLv2 text at the FSF Web site

RESOLVED FIXED in mozilla2.0b8

Status

()

Core
General
RESOLVED FIXED
7 years ago
7 years ago

People

(Reporter: summation, Assigned: reed)

Tracking

unspecified
mozilla2.0b8
Points:
---

Firefox Tracking Flags

(status1.9.2 .13-fixed, status1.9.1 .16-fixed)

Details

Attachments

(1 attachment)

(Reporter)

Description

7 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.2.11) Gecko/20101012 Firefox/3.6.11
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.2.11) Gecko/20101012 Firefox/3.6.11

A copy of the text for the GNU General Public License version 2 (GPLv2) is embedded in the Firefox browser. This license text can be viewed by accessing the about:license URL and then scrolling down. However, the license text gives an address for the Free Software Foundation (51 Franklin St, Fifth Floor, Boston, MA 02110-1301 USA) that is not the same as the address at the http://www.fsf.org/about/contact/ page (51 Franklin Street, Suite 500, Boston, MA 02110-1335 USA.) Also, the last statement in the embedded license reads "If this is what you want to do, use the GNU Library General Public License instead of this License."

At an FSF Web page about the GPLv2 (http://www.gnu.org/licenses/old-licenses/gpl-2.0.html), the license text ends with the statement "If this is what you want to do, use the GNU Lesser General Public License instead of this License." According to the FSF, the reference to "the GNU Library General Public License" probably indicates an older version of the GPLv2. (The GNU Library General Public License predated the GNU Lesser General Public License.)

It might be advisable to replace the current embedded GPLv2 text with the official and newer GPLv2 text from the FSF. In doing so, the text and structure of the GPLv2 should not be altered. Indeed, the GPLv2 includes the following directive:

Everyone is permitted to copy and distribute verbatim copies
of this license document, but changing it is not allowed.

(Ideally, it would be possible to use the GPLv3 instead of the GPLv2, but there may be code or other GPLv2-covered content that cannot be relicensed under the GPLv3.)

Reproducible: Always

Steps to Reproduce:
1. Access the about:license URL
2. Scroll down until the text of the GNU General Public License version 2 appears
(Assignee)

Updated

7 years ago
Component: General → General
OS: Mac OS X → All
Product: Firefox → Core
QA Contact: general → general
Hardware: x86 → All
(Assignee)

Comment 1

7 years ago
Created attachment 484633 [details] [diff] [review]
patch - v1

I went through both the GPL and the LGPL and compared their content line-by-line. All I could find were two GNU Lesser vs. GNU Library difference in the GPL, a minor line length issue, and St vs. Street difference in the LGPL. I've fixed the first two of these issues and left the last one along, as St is just fine (and is what is used everywhere else in both the GPL and LGPL, so not sure why one line in the LGPL uses Street instead).
Assignee: nobody → reed
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
Attachment #484633 - Flags: review?(gerv)
(Assignee)

Comment 2

7 years ago
(In reply to comment #0)
> However, the license text gives
> an address for the Free Software Foundation (51 Franklin St, Fifth Floor,
> Boston, MA 02110-1301 USA) that is not the same as the address at the
> http://www.fsf.org/about/contact/ page (51 Franklin Street, Suite 500, Boston,
> MA 02110-1335 USA.)

The address mentioned in the license text is exactly what the text versions of the GPLv2 and LGPLv2.1 use on www.gnu.org. Specifically, I used http://www.gnu.org/licenses/old-licenses/gpl-2.0.txt and http://www.gnu.org/licenses/old-licenses/lgpl-2.1.txt. I see no reason to change it.

> Also, the last statement in the embedded license reads "If
> this is what you want to do, use the GNU Library General Public License instead
> of this License."
> 
> At an FSF Web page about the GPLv2
> (http://www.gnu.org/licenses/old-licenses/gpl-2.0.html), the license text ends
> with the statement "If this is what you want to do, use the GNU Lesser General
> Public License instead of this License." According to the FSF, the reference to
> "the GNU Library General Public License" probably indicates an older version of
> the GPLv2. (The GNU Library General Public License predated the GNU Lesser
> General Public License.)

Indeed, thanks for the find. Fixed in my patch.

> (Ideally, it would be possible to use the GPLv3 instead of the GPLv2, but there
> may be code or other GPLv2-covered content that cannot be relicensed under the
> GPLv3.)

That's very much unlikely to happen for a variety of reasons and is off-topic for this bug. :)
Comment on attachment 484633 [details] [diff] [review]
patch - v1

r=gerv.

Gerv
Attachment #484633 - Flags: review?(gerv) → review+
(Assignee)

Updated

7 years ago
Attachment #484633 - Flags: approval2.0?
Drivers: there is no impact here on the string freeze because the license documents in about:license are not (or shouldn't be!) translated.

Gerv

Updated

7 years ago
Attachment #484633 - Flags: approval2.0? → approval2.0+
(Assignee)

Comment 5

7 years ago
http://hg.mozilla.org/mozilla-central/rev/86e5ad5f6aef
Status: ASSIGNED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla2.0b8
(Assignee)

Updated

7 years ago
Attachment #484633 - Flags: approval1.9.2.13?
Attachment #484633 - Flags: approval1.9.1.16?
Comment on attachment 484633 [details] [diff] [review]
patch - v1

Approved for 1.9.2.13 and 1.9.1.16, a=dveditz for release-drivers
Attachment #484633 - Flags: approval1.9.2.13?
Attachment #484633 - Flags: approval1.9.2.13+
Attachment #484633 - Flags: approval1.9.1.16?
Attachment #484633 - Flags: approval1.9.1.16+
(Assignee)

Comment 7

7 years ago
http://hg.mozilla.org/releases/mozilla-1.9.2/rev/e1d59378a7ae
status1.9.2: --- → .13-fixed
(Assignee)

Comment 8

7 years ago
http://hg.mozilla.org/releases/mozilla-1.9.1/rev/fecef32f84b0
status1.9.1: --- → .16-fixed
You need to log in before you can comment on or make changes to this bug.