Closed Bug 605774 Opened 9 years ago Closed 9 years ago

Can not download on stylecop.codeplex.com

Categories

(Core :: JavaScript Engine, defect)

x86
Windows 7
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 584603
mozilla2.0
Tracking Status
blocking2.0 --- betaN+

People

(Reporter: alice0775, Assigned: dmandelin)

References

()

Details

(Keywords: regression)

Build Identifier: 
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b8pre) Gecko/20101019
Firefox/4.0b8pre ID:20101019041714

(From http://forums.mozillazine.org/viewtopic.php?p=10036799#p10036799 )
I'm not able to download anything from any project site at Codeplext.com (e.g. http://stylecop.codeplex.com/).

When clicking the Download button on the right, a "License Agreement" dialog with Accept/Decline buttons should appear, but doesn't with Minefield. The site just turns grey-ish/opaque and you can press Esc to dismiss the invisible dialog.

And error shows in Error Console,
Error: d.call is not a function
Source file: http://i1.codeplex.com/scripts/v17184/i268435439/ScriptLoader.ashx
Line: 801

Reproducible: Always

Steps to Reproduce:
1. Start Minefield with new profile
2. Go URL ( http://stylecop.codeplex.com/ )
3. Click green "Download" button at the right side.

Actual Results:
 "License Agreement" dialog does not pop up.
  The site just turns grey-ish/opaque.
  
  And error shows in Error Console,
  Error: d.call is not a function
  Source file: http://i1.codeplex.com/scripts/v17184/i268435439/ScriptLoader.ashx
  Line: 801

Expected Results:
 "License Agreement" dialog should pop up.

Regression window in cached m-c hourly build:
Works:
http://hg.mozilla.org/mozilla-central/rev/16eac4b8b8e0
Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.2.5) Gecko/20100421 Firefox/4.0b6pre ID:20100911133215
Fails:
http://hg.mozilla.org/mozilla-central/rev/f1bd314e64ac
Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.2.5) Gecko/20100421 Firefox/4.0b6pre ID:20100911134652
Pushlog:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=16eac4b8b8e0&tochange=f1bd314e64ac

Regression window in TM nightly build:
Works:
http://hg.mozilla.org/tracemonkey/rev/f3e58c264932
Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.2.5) Gecko/20100421 Firefox/4.0b5pre ID:20100830044110
Fails:
http://hg.mozilla.org/tracemonkey/rev/cb719643afc5
Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.2.5) Gecko/20100421 Firefox/4.0b5pre ID:20100831185919
Pushlog:
http://hg.mozilla.org/tracemonkey/pushloghtml?fromchange=f3e58c264932&tochange=cb719643afc5
blocking2.0: --- → ?
blocking2.0: ? → betaN+
The regression window contains the JM landing. I'll bisect over that.
Assignee: general → dmandelin
Verified fixed by bug 584603.
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 584603
You need to log in before you can comment on or make changes to this bug.