After deleting an email the email opened next is unreadable

RESOLVED WORKSFORME

Status

RESOLVED WORKSFORME
8 years ago
8 years ago

People

(Reporter: krajcar.peter, Unassigned)

Tracking

x86
Windows Vista

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [closeme 2011-04-11])

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.0; cs; rv:1.9.2.10) Gecko/20100914 Firefox/3.6.10 ( .NET CLR 3.5.30729; .NET CLR 4.0.20506)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.0; cs; rv:1.9.2.9) Gecko/20100915 Thunderbird/3.1.4

Sometimes when I delete an email (or read confirmation) and open another email (not automatically by Thunderbird after email deletion but by clicking on email) that email is mixed up together from the deleted email and the one I've just opened. This means that this email is not decoded and I can read all the header information of first email (the deleted one) and the second one (the one I opened after deletion), but their bodies are URL (or base64 ?) encoded so they are hardly readable (all the letters with diacritics are encoded). If the opened email had attachments, they are shown as text presentation of this boundary and also encoded... We can say that attachments are gone...

Reproducible: Sometimes

Steps to Reproduce:
Don't know if this issue is reproducible and how cos it happens accidentally. Maybe this is a bug only when an email with diacritic letter in email body. Anyway, these are steps I usualy do when this issue happens:

1. Click on email, hit the [DEL] key on keyboard to delete it.
2. Email is moved to trash, Thunderbird automatically opens next email in the list.
3. Click on another email (no matter which or how old it is) - and this email is fuc*ed up...

I have only basic installation, with these extensions present: CompactHeader 1.2.4 and Extra Folder Columns 1.1.
Actual Results:  
This is described in the "Details" section...

Expected Results:  
Open the email as it should do in normal way...

I also tried to save the email to my PC (as .eml file) and after opening it (tried Thunderbird, Notepad, Wordpad) it was still unreadable. After opening an email via web client (e.g. directly at gmail.com) the email was readable. This means that only a local copy of email is fuc*ed up then...

As I'm not sure if it is a bug of Thunderbird or of it's CompactHeader extension, and as it happens only accidentaly, I'm selecting normal severity, even the major feature (reading of email) is broken...
(Reporter)

Updated

8 years ago
Version: unspecified → 3.1
Can you compact and rebuild the index on the offending folder and let us know if after that your TB works better ?
(Reporter)

Comment 2

8 years ago
Hello, can You, please, pet me up to how I should do that: "compact and rebuild the index on the offending folder" ?! Thank You.
Right click on the folder that you are having the issue with. Select compact. Once done select properties, click the rebuild button.

Comment 4

8 years ago
Peter, do you still see this issue?

If not, please change bug status to RESOLVED and resolution to WORKSFORME
Whiteboard: [closeme 2011-04-11]
(Reporter)

Comment 5

8 years ago
While the occurence of the problem was brutaly lowered, still this bug occurs from time to time.

Anyway I cannot say whether the update or cleaning up of folder helped.

Because nobody else is involved in finding of reason or solution of this bug I find this therefore as useless and am closing it...
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.