Quicktime Player functionality problem: The movie doesn't load into the browser window

RESOLVED WORKSFORME

Status

()

Core
Plug-ins
RESOLVED WORKSFORME
7 years ago
7 years ago

People

(Reporter: Anna (Waverley), Unassigned)

Tracking

Trunk
x86
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(3 attachments)

(Reporter)

Description

7 years ago
User-Agent:       Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:2.0b8pre) Gecko/20101019 Firefox/4.0b8pre
Build Identifier: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:2.0b8pre) Gecko/20101019 Firefox/4.0b8pre

When loading the specified page, the movie doesn't load into the browser window, but the context menu appears: Open with QuickTime Player(default), the video is downloaded and opened in the Player, not in the browser window.

Reproducible: Always

Steps to Reproduce:
1. Download and install the Quicktime Player for your platform: http://www.apple.com/quicktime/download/
    ** Mac Snow Leopard users will already have Quicktime installed, but you might need to update to the latest version if you have not been doing regular software updates.

2. Visit the test page here: http://pulsar.esm.psu.edu/Faculty/Gray/graphics/movies/126449main_katrina_fred_animation.mov

Actual Results:  
The movie isn't loaded in the browser window, but it is being downloaded and opened with QuickTime Player. 

Expected Results:  
After Step 2, the movie should load in the browser window and play. You be able to use the player controls to pause or stop the video, and then resume playing.
(Reporter)

Comment 1

7 years ago
Created attachment 484657 [details]
The final result
(Reporter)

Comment 2

7 years ago
Created attachment 484658 [details]
The context menu
(Reporter)

Comment 3

7 years ago
Created attachment 484660 [details]
The download manager
I can reproduce the problem with a new profile, but not with my existing profile. When I check the Applications preferences my working profile has it associated with QT (in Minefield), but a fresh profile does not, and I don't know how to get associated so that it plays in-content. This may have to do with how QT does file association, and I'm wondering if during installation of QT you were prompted to use it as your default player.

However, I do notice that in my working profile, the video plays but it is unresponsive to playback control clicks. I will file a different bug for that.
Component: General → Plug-ins
Product: Firefox → Core
QA Contact: general → plugins
Version: unspecified → Trunk
I wonder if bug 630648 and this are related.
Can those who were previously able to reproduce this still reproduce it?
> Can those who were previously able to reproduce this still reproduce it?

In today's Minefield nightly, of course.
I cannot get the test page to load using the latest nightly - keep getting connection timeouts. Same thing happens with Safari and Chrome.

Comment 9

7 years ago
Quick Time player works fine on the latest Firefox 6 Beta:
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:6.0) Gecko/20100101 Firefox/6.0

I verified this on http://trailers.apple.com/ since the link to the test page is broken. Setting this as Resolved. 
Anna, if you still experience this issue, feel free to reopen the bug.Thanks
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.