Login not possible because username automatically converted to lower case on leaving field

RESOLVED DUPLICATE of bug 499649

Status

()

Firefox
General
RESOLVED DUPLICATE of bug 499649
8 years ago
6 years ago

People

(Reporter: Hendrik Brummermann, Unassigned)

Tracking

4.0 Branch
x86_64
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (X11; Linux x86_64; rv:2.0b8pre) Gecko/20101012 Firefox-4.0/4.0b8pre
Build Identifier: Mozilla/5.0 (X11; Linux x86_64; rv:2.0b8pre) Gecko/20101012 Firefox-4.0/4.0b8pre

My username used to be spelled in lower case letters and I have a password saved for that variant.

It is now impossible to login using an upper case first letter because it is converted to lower case whenever I move the focus out of the input field.

I tried to use the mouse to click the login button or anywhere else. I tried to use the tabulator key. 

I can close the suggestion tool window by pressing ESC and the name will stay in upper case. But as soon as i leave the field, it is back to lower case.


This is a real issue because many database systems treat upper and lower case letters as not equal, this preventing login. It is not easily understandable how to delete the saved login information.

Reproducible: Always

Updated

7 years ago
Version: unspecified → 4.0 Branch
This bug was reported using a pre-release version of Firefox 4. Now that Firefox 4.0.1 final has been released, can you please update and retest your bug? A fresh profile would be a good starting place to test, 
http://support.mozilla.com/kb/Managing+profiles. If you continue to see the issue, can you please update this bug with your results?

Filter: firefox4prebugsunco

Comment 2

7 years ago
I did.

In my case, it was Firefox 4.0.1 on OS X 10.6.7.

See https://bugzilla.mozilla.org/show_bug.cgi?id=512101

Updated

6 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 499649
You need to log in before you can comment on or make changes to this bug.