Logins not retained on restart/refresh of page

RESOLVED WONTFIX

Status

()

Core
Networking: Cookies
--
major
RESOLVED WONTFIX
8 years ago
8 years ago

People

(Reporter: Jim Jeffery not reading bug-mail 1/2/11, Unassigned)

Tracking

({regression})

Firefox Tracking Flags

(Not tracked)

Details

Using today's nightly build login into bugzilla.  
Close/restart the browser 
refresh the page, note your not logged in anymore.

regression: 
K:\Moz2\20101019181208 8c07f7bd6d3a ok
K:\Moz2\20101019194051 44ab0d4958f6 bad
Keywords: regression
I renamed cookies.sqlite in my profile and now things appear to be working.

Comment 2

8 years ago
Can you email me your original cookies.sqlite? I think that's the only way I can reproduce here, since we've pretty exhaustively tested the migration code...
On its way...

Comment 4

8 years ago
Hmm. So your database has a schema version of 3, but the table was created with a creationTime column. Which only happens for schema 4.

How did you manage to create this monster? I'm guessing you deleted your database when I landed these patches last time, and didn't delete it again when I backed the changes out. So you still had a funny-looking database from then, which had the creationTime column added but didn't make it far enough to change the schema version.

Is this correct? If so, there's nothing more to do here; I'm not worried about databases from the few hours those initial patches were in.
Dan, yes.. exactly - I do believe I created a new cookies file when you landed this the first time, and since I didn't appear to have any issues when backed-out I just forgot about the whole thing. That's what happens when you get old (63). 

Sorry to have bothered..  close as INVALID ?

Comment 6

8 years ago
Heh, no problem. Better that we found this and made sure it's OK than otherwise.

It's a valid bug, so let's do WONTFIX.
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.