selected encoding for tab doesn't save

NEW
Unassigned

Status

Thunderbird
Toolbars and Tabs
8 years ago
3 years ago

People

(Reporter: metaluger, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; uk; rv:1.9.2.11) Gecko/20101012 Firefox/3.6.11
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; uk; rv:1.9.2.11) Gecko/20101013 Thunderbird/3.1.5

I opened mail in tab. Encoding detects wrong, win-1251 instead of koi8-r. So, I have selected koi8-r. Switch to main tab. Switch to mail tab again. See, that encoding is wrong (win-1251).

Reproducible: Always

Steps to Reproduce:
1. Open main with wrong encoding in second tab
2. Select right encoding
3. Switch to main tab (ctrl+tab)
4. Switch to mail tab (ctrl+tab)
Actual Results:  
encoding is wrong

Expected Results:  
encoding must be saved, if it changed by user manually
Status: UNCONFIRMED → NEW
Component: General → Toolbars and Tabs
Ever confirmed: true
QA Contact: general → toolbars-tabs
(Reporter)

Comment 1

7 years ago
still occurs in 3.1.10

Comment 2

7 years ago
(In reply to metaluger from comment #0)
> User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; uk; rv:1.9.2.11)
<b>test, test</b>
(Reporter)

Comment 3

7 years ago
(In reply to fonar101 from comment #2)
> (In reply to metaluger from comment #0)
> > User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; uk; rv:1.9.2.11)
> <b>test, test</b>

Sorry, what do you mean?

P.S. Bug still present in 6.0.2
You need to log in before you can comment on or make changes to this bug.