Cyclic Service Dependency between nsHTTPHandler::InitUserAgentComponents() and nsLayoutModule::SetUserAgent()

VERIFIED DUPLICATE of bug 46488

Status

()

Core
Networking: HTTP
P3
normal
VERIFIED DUPLICATE of bug 46488
18 years ago
16 years ago

People

(Reporter: Patrick C. Beard, Assigned: Gagan)

Tracking

Trunk
PowerPC
Mac System 9.x
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

18 years ago
nsHTTPHandler::InitUserAgentComponents() is called when the HTTP protocol handler 
is first created via the service manager. At the URL above is a line of that 
method that calls mPrefs->GetLocalizedUnicharPref(UA_PREF_PREFIX "locale", which 
eventually reaches nsLayoutModule::SetUserAgent() (see attached stack crawl to 
see how that happens). nsLayoutModule::SetUserAgent() in turn tries to access the 
service signified by kHTTPHandlerCID, which of course is nsHTTPHandler again. I 
don't know how this circularity creeped in, nor how it should be fixed.

One clue:  I'm seeing this when running the Mac PowerPlant embedding client.
(Reporter)

Comment 1

18 years ago
Created attachment 19448 [details]
stack crawl showing cyclic service dependency
The question is: why doesn't this happen with SeaMonkey? After all, what
initiates this is a simple URL load. It may be that
GetDefaultLocalizedUnicharPref is called earlier in SeaMonkey, chrome is
initialized earlier, or something. The circular dependency is there but is being
masked somehow. I'll check it out. 
Status: NEW → ASSIGNED

Comment 3

18 years ago

*** This bug has been marked as a duplicate of 46488 ***
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE

Comment 4

16 years ago
VERIFIED, fixed by Layout.
Status: RESOLVED → VERIFIED
Component: Networking → Networking: HTTP
QA Contact: tever → benc
You need to log in before you can comment on or make changes to this bug.