If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Recently Closed Windows item should be greyed out after using it.

RESOLVED DUPLICATE of bug 589246

Status

()

Firefox
Session Restore
RESOLVED DUPLICATE of bug 589246
7 years ago
7 years ago

People

(Reporter: Teodosia Pop, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

1.96 KB, application/x-javascript
Details
203.06 KB, image/png
Details
(Reporter)

Description

7 years ago
User-Agent:       Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:2.0b8pre) Gecko/20101020 Firefox/4.0b8pre
Build Identifier: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:2.0b8pre) Gecko/20101020 Firefox/4.0b8pre

After using the "Recently Closed Windows" from "History" should be greyed out after using it to restore a window.

Reproducible: Always

Steps to Reproduce:
1.Open a new window from an existing one
2.Navigate to a website
3.Close the window
4.Click History menu > Recently Closed Windows
5.Select the window you recently closed
6.Click History menu


Actual Results:  
The History menu > Recently Closed Windows item is still available even if there are no more windows to restore.

Expected Results:  
The History menu > Recently Closed Windows item should be grayed out.
I'm unable to reproduce this problem on the same build version, following the steps in comment #0. I'll double check on a different OS.
Component: General → Session Restore
QA Contact: general → session.restore
Teodosia: are you using the "Move to New Window" in Step 1? I was able to repro this issue on Windows, but no on Mac with the latest nightly.
(Reporter)

Comment 3

7 years ago
I checked again. After the steps I mentioned, if I restart Minefield, "Recently Closed Windows" is available, but there are no windows to choose from.
(In reply to comment #3)
> I checked again. After the steps I mentioned, if I restart Minefield, "Recently
> Closed Windows" is available, but there are no windows to choose from.

Can you make a copy of your sessionstore.bak file in your profile folder - that could come in useful for other people to reproduce the problem. If you feel comfortable uploading the file here, great. Otherwise feel free to email it directly to me (I work on the session restore code).

If you look at the error console immediately after attempting trying to find a window do choose from, do you see any errors?

(In reply to comment #2)
> Teodosia: are you using the "Move to New Window" in Step 1? I was able to repro
> this issue on Windows, but no on Mac with the latest nightly.

On Win/Linux we lie a little bit, so you could be hitting that. We need to keep a non-popup window in our closed window list at all times (cf. bug 491590)
(Reporter)

Comment 5

7 years ago
Created attachment 485233 [details]
sessionstore.js

This is the sessionstore.js file after I performed the described steps.
Ok, so I can see the problem when I use your sessionstore.js. It looks like your _closedWindows data is corrupted - somehow there's a window entry but it doesn't have any tabs.

This sounds exactly like the problem in bug 589246, but I don't think it should be happening on OSX.

I couldn't reproduce the problem using your steps to reproduce. Can you start with a completely new session (no sessionstore.js in your profile) and describe exactly how you got into this state (any extensions, home page, exact web sites, etc).
(Reporter)

Comment 7

7 years ago
I've skipped one step in "Steps to reproduce" when I've logged the bug.
The steps are:

1.Open FF
2.Navigate to google.com
3.Open a new window from the current one
4.Navigate to wikipedia.com
5.Close the new newly opened window (the one with wikipedia)
6.Check the History menu > Recently Closed Windows. Up until here it's all as expected.
7.Close the remaining window (the one with the google) by clicking on the red X button from the upper left corner.
8.Reopen FF by clicking on the FF icon from the dock and check the History menu > Recently Closed Windows. 

After step 8, the Recently Closed Windows is enabled in History menu, but when you hover over no options are displayed.
See the screenshot.
(Reporter)

Comment 8

7 years ago
Created attachment 485737 [details]
screenshot
Ah these STR make it much clearer and now I can see the issue. I think this is probably the same issue as bug 589246.
Upon further investigation, this is a duplicate of bug 589246. My patch there fixes this problem.
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 589246
You need to log in before you can comment on or make changes to this bug.