Firefox 4.0b8pre Crash Report [@ js_NewGCShortString(JSContext*) ]

RESOLVED DUPLICATE of bug 605836

Status

()

Core
JavaScript Engine
--
critical
RESOLVED DUPLICATE of bug 605836
7 years ago
7 years ago

People

(Reporter: Tomcat, Unassigned)

Tracking

({crash, regression})

Trunk
x86
Windows 7
crash, regression
Points:
---

Firefox Tracking Flags

(blocking2.0 betaN+)

Details

(Whiteboard: [crashkill], crash signature, URL)

(Reporter)

Description

7 years ago
Firefox 4.0b8pre Crash Report [@ js_NewGCShortString(JSContext*) ]  - windows only, seems to be a 4.0b8pre Regression.

so far no comments for this crashes - http://crash-stats.mozilla.com/report/list?signature=js_NewGCShortString%28JSContext*%29

Signature	js_NewGCShortString(JSContext*)
UUID	3660fb54-cafd-4765-9fb2-ca0492101020
Time 	2010-10-20 08:47:40.86973
Uptime	1617
Last Crash	12118 seconds (3.4 hours) before submission
Install Age	2053 seconds (34.2 minutes) since version was first installed.
Product	Firefox
Version	4.0b8pre
Build ID	20101020042802
Branch	2.0
OS	Windows NT
OS Version	6.1.7600
CPU	x86
CPU Info	GenuineIntel family 6 model 23 stepping 6
Crash Reason	EXCEPTION_ACCESS_VIOLATION_READ
Crash Address	0x20
User Comments	
App Notes 	AdapterVendorID: 10de, AdapterDeviceID: 06ec
Processor Notes 	
EMCheckCompatibility	False
Crashing Thread
Frame 	Module 	Signature [Expand] 	Source
0 	mozjs.dll 	js_NewGCShortString 	js/src/jsgcinlines.h:154
1 	mozjs.dll 	js_ConcatStrings 	js/src/jsstr.cpp:290
2 	mozjs.dll 	js::Interpret 	js/src/jsinterp.cpp:3590
3 	mozjs.dll 	js::RunScript 	js/src/jsinterp.cpp:638
4 	mozjs.dll 	js::Invoke 	js/src/jsinterp.cpp:747
5 	mozjs.dll 	js::ExternalInvoke 	js/src/jsinterp.cpp:871
6 	mozjs.dll 	JS_CallFunctionValue 	js/src/jsapi.cpp:4961
7 	xul.dll 	nsJSContext::CallEventHandler 	dom/base/nsJSEnvironment.cpp:2142
8 	xul.dll 	nsGlobalWindow::RunTimeout 	dom/base/nsGlobalWindow.cpp:8880
9 	xul.dll 	nsGlobalWindow::TimerCallback 	dom/base/nsGlobalWindow.cpp:9225
10 	xul.dll 	nsTimerImpl::Fire 	xpcom/threads/nsTimerImpl.cpp:425
11 	xul.dll 	nsTimerEvent::Run 	xpcom/threads/nsTimerImpl.cpp:517
12 	xul.dll 	nsThread::ProcessNextEvent 	xpcom/threads/nsThread.cpp:547
13 	xul.dll 	NS_InvokeByIndex_P 	xpcom/reflect/xptcall/src/md/win32/xptcinvoke.cpp:102
14 	xul.dll 	XPCWrappedNative::CallMethod 	js/src/xpconnect/src/xpcwrappednative.cpp:2285
15 	xul.dll 	XPC_WN_CallMethod 	js/src/xpconnect/src/xpcwrappednativejsops.cpp:1631
16 	mozjs.dll 	js::Interpret 	js/src/jsinterp.cpp:4716
17 	mozjs.dll 	js::RunScript 	js/src/jsinterp.cpp:638
18 	mozjs.dll 	js::Invoke 	js/src/jsinterp.cpp:747
19 	mozjs.dll 	js_fun_apply 	js/src/jsfun.cpp:2369
20 	mozjs.dll 	js::Interpret 	js/src/jsinterp.cpp:4716
21 	mozjs.dll 	js::RunScript 	js/src/jsinterp.cpp:638
22 	mozjs.dll 	js::Invoke 	js/src/jsinterp.cpp:747
23 	mozjs.dll 	js_fun_call 	js/src/jsfun.cpp:2248
24 	mozjs.dll 	js::Interpret 	js/src/jsinterp.cpp:4716
25 	mozjs.dll 	js::RunScript 	js/src/jsinterp.cpp:638
26 	mozjs.dll 	js::Invoke 	js/src/jsinterp.cpp:747
27 	mozjs.dll 	js::ExternalInvoke 	js/src/jsinterp.cpp:871
28 	mozjs.dll 	JS_CallFunctionValue 	js/src/jsapi.cpp:4961
29 	xul.dll 	nsXPCWrappedJSClass::CallMethod 	js/src/xpconnect/src/xpcwrappedjsclass.cpp:1694
30 	xul.dll 	nsXPCWrappedJS::CallMethod 	js/src/xpconnect/src/xpcwrappedjs.cpp:571
31 	xul.dll 	PrepareAndDispatch 	xpcom/reflect/xptcall/src/md/win32/xptcstubs.cpp:114
32 	xul.dll 	SharedStub 	xpcom/reflect/xptcall/src/md/win32/xptcstubs.cpp:141
33 	xul.dll 	nsNavHistory::RunInBatchMode 	toolkit/components/places/src/nsNavHistory.cpp:4407
34 	xul.dll 	NS_InvokeByIndex_P 	xpcom/reflect/xptcall/src/md/win32/xptcinvoke.cpp:102
(Reporter)

Updated

7 years ago
blocking2.0: --- → ?

Comment 1

7 years ago
probably should be lumped in with 604756 and related bugs.

Updated

7 years ago
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 605836

Updated

7 years ago
blocking2.0: ? → betaN+
Crash Signature: [@ js_NewGCShortString(JSContext*) ]
You need to log in before you can comment on or make changes to this bug.