Closed Bug 605925 Opened 9 years ago Closed 7 years ago

Intermittent failure in modules/plugin/test/reftest/pluginproblemui-direction-2.html | assertion count 1 is more than expected 0 assertions

Categories

(Core :: Plug-ins, defect)

x86_64
macOS
defect
Not set

Tracking

()

RESOLVED WORKSFORME

People

(Reporter: ehsan, Unassigned)

References

Details

(Keywords: intermittent-failure)

http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1287598094.1287599410.814.gz
Rev3 MacOSX Snow Leopard 10.6.2 mozilla-central debug test reftest on 2010/10/20 11:08:14

REFTEST TEST-START | file:///Users/cltbld/talos-slave/mozilla-central_snowleopard-debug_test-reftest/build/reftest/tests/modules/plugin/test/reftest/pluginproblemui-direction-2.html
++DOMWINDOW == 12 (0x1189597c8) [serial = 10166] [outer = 0x116fdc2f0]
For application/x-test found plugin Test.plugin
### XPCOM_MEM_BLOAT_LOG defined -- logging bloat/leaks to /var/folders/H5/H5TD8hgwEqKq9hgKlayjWU+++TM/-Tmp-/tmpl3hhM1/runreftest_leaks_plugin_pid358.log
[loaded plugin /private/var/folders/H5/H5TD8hgwEqKq9hgKlayjWU+++TM/-Tmp-/tmpl3hhM1/plugins/Test.plugin]

###!!! [Parent][RPCChannel] Error: Channel error: cannot send/recv

WARNING: Failed to send message!: file /builds/slave/mozilla-central-macosx64-debug/build/dom/plugins/PluginScriptableObjectParent.cpp, line 219
JavaScript error: file:///Users/cltbld/talos-slave/mozilla-central_snowleopard-debug_test-reftest/build/reftest/tests/modules/plugin/test/reftest/pluginproblemui-direction-2.html, line 22: Error calling method on NPObject!

###!!! [Parent][AsyncChannel] Error: Channel error: cannot send/recv

WARNING: Unable to retrieve pref: plugins.unloadASAP: file /builds/slave/mozilla-central-macosx64-debug/build/modules/plugin/base/src/nsPluginHost.cpp, line 316
REFTEST TEST-START | file:///Users/cltbld/talos-slave/mozilla-central_snowleopard-debug_test-reftest/build/reftest/tests/modules/plugin/test/reftest/pluginproblemui-direction-2-ref.html
++DOMWINDOW == 13 (0x1198ac148) [serial = 10167] [outer = 0x116fdc2f0]
For application/x-test found plugin Test.plugin
### XPCOM_MEM_BLOAT_LOG defined -- logging bloat/leaks to /var/folders/H5/H5TD8hgwEqKq9hgKlayjWU+++TM/-Tmp-/tmpl3hhM1/runreftest_leaks_plugin_pid359.log
[loaded plugin /private/var/folders/H5/H5TD8hgwEqKq9hgKlayjWU+++TM/-Tmp-/tmpl3hhM1/plugins/Test.plugin]
###!!! ASSERTION: TagForPlugin has failed: 'PR_FALSE', file /builds/slave/mozilla-central-macosx64-debug/build/modules/plugin/base/src/nsPluginHost.cpp, line 1189
nsPluginHost::TagForPlugin [modules/plugin/base/src/nsPluginHost.cpp:1190]
nsPluginHost::StopPluginInstance [modules/plugin/base/src/nsPluginHost.cpp:3063]
DoStopPlugin [layout/generic/nsObjectFrame.cpp:2450]
nsStopPluginRunnable::Run [layout/generic/nsObjectFrame.cpp:2493]
nsStopPluginRunnable::Notify [layout/generic/nsObjectFrame.cpp:2461]
nsTimerImpl::Fire [xpcom/threads/nsTimerImpl.cpp:429]
nsTimerEvent::Run [xpcom/threads/nsTimerImpl.cpp:519]
nsThread::ProcessNextEvent [xpcom/threads/nsThread.cpp:547]
NS_ProcessPendingEvents_P [nsThreadUtils.cpp:200]
nsBaseAppShell::NativeEventCallback [widget/src/xpwidgets/nsBaseAppShell.cpp:132]
nsAppShell::ProcessGeckoEvents [widget/src/cocoa/nsAppShell.mm:400]
CoreFoundation + 0x4d11d
CoreFoundation + 0x4b469
CoreFoundation + 0x4ac2f
HIToolbox + 0x2ea4e
HIToolbox + 0x2e7b1
HIToolbox + 0x2e70c
AppKit + 0x441f2
-AppKit + 0x43b41
-AppKit + 0x9747
nsAppShell::Run [widget/src/cocoa/nsAppShell.mm:746]
nsAppStartup::Run [toolkit/components/startup/src/nsAppStartup.cpp:191]
XRE_main [toolkit/xre/nsAppRunner.cpp:3682]
main [browser/app/nsBrowserApp.cpp:158]
WARNING: Unable to retrieve pref: plugins.unloadASAP: file /builds/slave/mozilla-central-macosx64-debug/build/modules/plugin/base/src/nsPluginHost.cpp, line 316

###!!! [Parent][RPCChannel] Error: Channel error: cannot send/recv

WARNING: Failed to send message!: file /builds/slave/mozilla-central-macosx64-debug/build/dom/plugins/PluginScriptableObjectParent.cpp, line 219
JavaScript error: file:///Users/cltbld/talos-slave/mozilla-central_snowleopard-debug_test-reftest/build/reftest/tests/modules/plugin/test/reftest/pluginproblemui-direction-2-ref.html, line 22: Error calling method on NPObject!

###!!! [Parent][RPCChannel] Error: Channel error: cannot send/recv


###!!! [Parent][RPCChannel] Error: Channel error: cannot send/recv

WARNING: Unable to retrieve pref: plugins.unloadASAP: file /builds/slave/mozilla-central-macosx64-debug/build/modules/plugin/base/src/nsPluginHost.cpp, line 316
WARNING: Unable to retrieve pref: plugins.unloadASAP: file /builds/slave/mozilla-central-macosx64-debug/build/modules/plugin/base/src/nsPluginHost.cpp, line 316
REFTEST TEST-PASS | file:///Users/cltbld/talos-slave/mozilla-central_snowleopard-debug_test-reftest/build/reftest/tests/modules/plugin/test/reftest/pluginproblemui-direction-2.html |
REFTEST INFO | Loading a blank page
++DOMWINDOW == 14 (0x11e89ffd8) [serial = 10168] [outer = 0x116fdc2f0]
NEXT ERROR REFTEST TEST-UNEXPECTED-FAIL | file:///Users/cltbld/talos-slave/mozilla-central_snowleopard-debug_test-reftest/build/reftest/tests/modules/plugin/test/reftest/pluginproblemui-direction-2.html | assertion count 1 is more than expected 0 assertions
Compare bug 567367 -- maybe disabling pluginproblemui-direction-1.html on OS X punted the assertion to pluginproblemui-direction-2.html?
(In reply to comment #1)
> Compare bug 567367 -- maybe disabling pluginproblemui-direction-1.html on OS X
> punted the assertion to pluginproblemui-direction-2.html?

Seems plausible.  Do you suggest we disable this other test on OS X as well?
I don't think so -- IIRC the first test was disabled because it was intermittently failing, not because of assertions, but I can't say I really understand the issues here.
Mass marking whiteboard:[orange] bugs WFM (to clean up TBPL bug suggestions) that:
* Haven't changed in > 6months
* Whose whiteboard contains none of the strings: {disabled,marked,random,fuzzy,todo,fails,failing,annotated,leave open,time-bomb}
* Passed a (quick) manual inspection of bug summary/whiteboard to ensure they weren't a false positive.

I've also gone through and searched for cases where the whiteboard wasn't labelled correctly after test disabling, by using attachment description & basic comment searches. However if the test for which this bug was about has in fact been disabled/annotated/..., please accept my apologies & reopen/mark the whiteboard appropriately so this doesn't get re-closed in the future (and please ping me via IRC or email so I can try to tweak the saved searches to avoid more edge cases).

Sorry for the spam! Filter on: #FFA500
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → WORKSFORME
Whiteboard: [orange]
You need to log in before you can comment on or make changes to this bug.