Wikipedias OpenSearch does not work on secure.wikimedia.org, even if the original entry is removed

RESOLVED INVALID

Status

()

Firefox
Search
RESOLVED INVALID
8 years ago
8 years ago

People

(Reporter: Christian Sturm, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b6) Gecko/20100101 Firefox/4.0b6
Build Identifier: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b6) Gecko/20100101 Firefox/4.0b6

I am not able to add the German, secure.wikimedia.org version of Wikipedia to my search bar. OpenSearch is present and it works using Firefox 3.6, but not Firefox 4. For some reason this only happens with the German version of Wikipedia.

Important: There is a known problem, which causes similar behaviour. You can't add the secure version of Wikipedia, if you already have added the non-secure version. The reason seems to be a naming overlap. Maybe this should also be fixed, but I guess an other bug report should be opened for this.

I don't know about the inner workings, but is it possible that the entry somehow stays present, but gets hidden (for the reset option to work for example)? This could cause the name overlap to still be present.

I also tried this on GNU/Linux.

Reproducible: Always

Steps to Reproduce:
Maybe one should use the German version of Firefox (and Wikipedia) for this, I haven't tried it with others yet. It could be possible that it only occurs if both the Firefox and Wikipedia are the same language.

1. Load https://secure.wikimedia.org/wikipedia/de/wiki/Wikipedia:Hauptseite
2. Remove the original Wikipedia entry from the search bar
Actual Results:  
No 'Wikipedia (de) hinzufügen' is present.

Expected Results:  
'Wikipedia (de) hinzufügen' should be present.
You indeed can't have multiple search engines with the same name installed. You also cannot completely remove engines that are included as part of the application - when you "remove" them, they're actually just hidden. That's covered by bug 353056, and it sounds like what's happening here - the name of the engine advertised at that site is "Wikipedia (de)", which I think is the same as the engine we ship for de builds.

So I believe this is a duplicate of bug 353056 :)
(Reporter)

Comment 2

8 years ago
I am not sure, if it is the same. As I wrote in Firefox 3 you could simply remove the original search plugin. That's not the case here.
Nothing has changed in Firefox 3 in this regard. Are you sure you observed different behavior there? It's possible the engine shipped with the 3.0 build may just have had a different title than the plugin being advertised on Wikipedia.
(Reporter)

Comment 4

8 years ago
After some testing I figured out it's a Wikipedia bug. I already reported it. Sorry about that!
(Reporter)

Updated

8 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → INVALID
What's the wikipedia bug, out of curiosity?
You need to log in before you can comment on or make changes to this bug.