Closed Bug 605949 Opened 9 years ago Closed 9 years ago

Intermittent test_bug384052.js | test failed (with xpcshell return code: 0) and -1 == -2

Categories

(Toolkit :: Add-ons Manager, defect)

x86_64
macOS
defect
Not set

Tracking

()

VERIFIED FIXED
mozilla2.0b7

People

(Reporter: philor, Assigned: mossop)

References

Details

(Keywords: intermittent-failure)

Attachments

(1 file)

This has probably been happening for a while, on 10.6, where xpcshell was hidden. I did see a few other instances while I was looking back through the last few days for something else.

http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1287605368.1287606955.6407.gz
Rev3 MacOSX Snow Leopard 10.6.2 mozilla-central opt test xpcshell on 2010/10/20 13:09:28
s: talos-r3-snow-011

TEST-UNEXPECTED-FAIL | /Users/cltbld/talos-slave/mozilla-central_snowleopard_test-xpcshell/build/xpcshell/tests/toolkit/mozapps/extensions/test/xpcshell-unpack/test_bug384052.js | test failed (with xpcshell return code: 0), see following log:
  >>>>>>>
  TEST-INFO | (xpcshell/head.js) | test 1 pending
TEST-INFO | (xpcshell/head.js) | test 2 pending
*** LOG addons.manager: Application has been upgraded
*** LOG addons.xpi: startup
*** LOG addons.xpi: checkForChanges
*** LOG addons.xpi: Migrating data from schema 0
*** LOG addons.xpi: Database is missing, recreating
*** LOG addons.xpi: Creating database schema
*** LOG addons.xpi: New add-on test@mozilla.org installed in app-profile
*** LOG addons.xpi: Updating database with changes to installed add-ons
*** LOG addons.xpi: Updating add-on states
*** LOG addons.xpi: Writing add-ons list
TEST-INFO | (xpcshell/head.js) | test 2 finished
TEST-INFO | (xpcshell/head.js) | running event loop
*** LOG addons.updates: Requesting http://127.0.0.1:4444/?itemID=test@mozilla.org&custom1=custom_parameter_1&custom2=custom_parameter_2
*** WARN addons.updates: Request timed out
TEST-UNEXPECTED-FAIL | /Users/cltbld/talos-slave/mozilla-central_snowleopard_test-xpcshell/build/xpcshell/tests/toolkit/mozapps/extensions/test/xpcshell-unpack/test_bug384052.js | -1 == -2 - See following stack:
JS frame :: /Users/cltbld/talos-slave/mozilla-central_snowleopard_test-xpcshell/build/xpcshell/head.js :: do_throw :: line 420
JS frame :: /Users/cltbld/talos-slave/mozilla-central_snowleopard_test-xpcshell/build/xpcshell/head.js :: do_check_eq :: line 450
JS frame :: /Users/cltbld/talos-slave/mozilla-central_snowleopard_test-xpcshell/build/xpcshell/tests/toolkit/mozapps/extensions/test/xpcshell-unpack/test_bug384052.js :: anonymous :: line 116
JS frame :: resource://gre/modules/XPIProvider.jsm :: anonymous :: line 5401
JS frame :: resource://gre/modules/XPIProvider.jsm :: UC_onUpdateCheckError :: line 5494
JS frame :: resource://gre/modules/AddonUpdateChecker.jsm :: UP_notifyError :: line 520
JS frame :: resource://gre/modules/AddonUpdateChecker.jsm :: UP_notify :: line 533
TEST-INFO | (xpcshell/head.js) | exiting test
*** LOG addons.xpi: Exception calling UpdateListener method onUpdateFinished: 2147500036
*** LOG addons.xpi: shutdown
Duplicate of this bug: 605948
Attached patch patch rev 1Splinter Review
This test is kinda flakey, relying on connections to 127.0.0.1 to do the same thing everytime. This changes to using the http server to return a failure and verify that the requested URL was correct.
Assignee: nobody → dtownsend
Status: NEW → ASSIGNED
Attachment #486090 - Flags: review?(robert.bugzilla)
Landed: http://hg.mozilla.org/mozilla-central/rev/965dc117adc0
Status: ASSIGNED → RESOLVED
Closed: 9 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla2.0b8
Target Milestone: mozilla2.0b8 → mozilla2.0b7
No more failure since the patch has been landed. Marking as verified fixed.
Status: RESOLVED → VERIFIED
Flags: in-testsuite+
Flags: in-litmus-
Whiteboard: [orange]
You need to log in before you can comment on or make changes to this bug.