Closed Bug 605965 Opened 9 years ago Closed 9 years ago

Memory leak when downloading files

Categories

(Firefox :: General, defect, major)

x86
Windows XP
defect
Not set
major

Tracking

()

RESOLVED DUPLICATE of bug 564710

People

(Reporter: nickdewing, Unassigned)

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2.11) Gecko/20101012 Firefox/3.6.11 ( .NET CLR 3.5.30729)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2.11) Gecko/20101012 Firefox/3.6.11 ( .NET CLR 3.5.30729)

I was downloading 300-600MB files, and my computer became unresponsive.  Upon checking my processes, I noticed Firefox was taking about 300,000KB of ram.  A few seconds after the download stopped, the memory was freed (I was downloading an ISO from the Microsoft VLK portal).  
To verify, I cleared my cache and restarted Firefox.  Then, I started to download another large file from a a different source.  I was watching the process and Firefox would start at about 90,000KB and after the first few megs, it would start going up.  I only have 1 tab open and am running the download (69MB of a 316MB file downloaded) and I'm at 240,000KB of ram just for Firefox.

Reproducible: Always

Steps to Reproduce:
1. Start a large file download (I've downloaded ISO files from the Microsoft VLK portal and Windows XP Service Pack 3 from Softpedia).
2. The leak doesn't become noticeable until you have downloaded about 15-20MB of the file.
3. Watch Firefox in a process manager.
Actual Results:  
Firefox's memory usage keeps climbing as the file downloads, after reaching 320,000KB of RAM usage for Firefox (1 tab and the download) I decided to stop the download.  I paused the download (to see what happens), and after about 5 seconds the memory was freed and Firefox dropped to 95,000KB of ram usage.
I checked the .part file to see that it was actually writing the file, which it was.  

Expected Results:  
I did this same test in Google Chrome and the memory would only slightly increase and then release.

I work in IT so I'm usually running many processes (I have 4GB of RAM), and that is how I noticed this problem.  I was downloading a large file, went to get coffee, and when I came back my computer was unresponsive.  When I checked the memory usage, I noticed Firefox was off the charts.  I killed a few tabs (which took was really slow) and a few other processes, but my computer was still unresponsive.  However, a few seconds after my download finished everything returned to normal.
I'm going to flag this as "Major" severity because my Firefox did hang for a few minutes and I believe most users would restart their computer (if they forced a reboot I wouldn't be surprised).  I would almost mark it as "Critical", but like I said the problem corrected itself once the download was finished.
I tested this with a clean profile (no add-ons) and it seems to have resolved this issue.
Firebug is known to cause this (bug 567988), and a few reports indicate that new profile fixed the issues without indicating what extension caused the problem. If you figure out the extension responsible, please contact its developer to let them know of this issue.
Status: UNCONFIRMED → RESOLVED
Closed: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 564710
You need to log in before you can comment on or make changes to this bug.