Crash in [@ PL_DHashTableOperate | nsTHashtable<nsBaseHashtableET<nsUint32HashKey, nsAutoPtr<`anonymous namespace''::DatabaseInfoHash> > >::RemoveEntry(unsigned int const&) ]

RESOLVED DUPLICATE of bug 599341

Status

()

Core
Plug-ins
RESOLVED DUPLICATE of bug 599341
7 years ago
7 years ago

People

(Reporter: WonderCsabo, Unassigned)

Tracking

Trunk
x86
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

7 years ago
User-Agent:       Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b8pre) Gecko/20101020 Firefox/4.0b8pre
Build Identifier: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b8pre) Gecko/20101020 Firefox/4.0b8pre

Signature	PL_DHashTableOperate | nsTHashtable<nsBaseHashtableET<nsUint32HashKey, nsAutoPtr<`anonymous namespace''::DatabaseInfoHash> > >::RemoveEntry(unsigned int const&)
UUID	2889f5fc-c296-40ff-a5ca-b94e62101020
Time 	2010-10-20 11:01:38.773512
Uptime	21
Last Crash	24 seconds before submission
Install Age	876 seconds (14.6 minutes) since version was first installed.
Product	Firefox
Version	4.0b8pre
Build ID	20101020042802
Branch	2.0
OS	Windows NT
OS Version	6.1.7600
CPU	x86
CPU Info	GenuineIntel family 6 model 23 stepping 10
Crash Reason	EXCEPTION_ACCESS_VIOLATION_READ
Crash Address	0x2c8
User Comments	
App Notes 	AdapterVendorID: 1002, AdapterDeviceID: 9552
Processor Notes 	
EMCheckCompatibility	False
Crashing Thread
Frame 	Module 	Signature [Expand] 	Source
0 	xul.dll 	PL_DHashTableOperate 	obj-firefox/xpcom/build/pldhash.c:615
1 	xul.dll 	nsTHashtable<nsBaseHashtableET<nsUint32HashKey,nsAutoPtr<`anonymous namespace'::DatabaseInfoHash> > >::RemoveEntry 	obj-firefox/dist/include/nsTHashtable.h:201
2 	xul.dll 	nsObjectFrame::StopPluginInternal 	layout/generic/nsObjectFrame.cpp:2523
3 	xul.dll 	nsObjectFrame::DestroyFrom 	layout/generic/nsObjectFrame.cpp:675
4 	xul.dll 	nsContainerFrame::DestroyFrom 	layout/generic/nsContainerFrame.cpp:272
5 	xul.dll 	nsBlockFrame::DestroyFrom 	layout/generic/nsBlockFrame.cpp:320
6 	xul.dll 	nsBlockFrame::DestroyFrom 	layout/generic/nsBlockFrame.cpp:320
7 	xul.dll 	nsContainerFrame::DestroyFrom 	layout/generic/nsContainerFrame.cpp:272
8 	xul.dll 	nsContainerFrame::DestroyFrom 	layout/generic/nsContainerFrame.cpp:272
9 	xul.dll 	nsContainerFrame::DestroyFrom 	layout/generic/nsContainerFrame.cpp:272
10 	xul.dll 	nsContainerFrame::DestroyFrom 	layout/generic/nsContainerFrame.cpp:272
11 	xul.dll 	nsTableFrame::DestroyFrom 	layout/tables/nsTableFrame.cpp:269
12 	xul.dll 	nsContainerFrame::DestroyFrom 	layout/generic/nsContainerFrame.cpp:272
13 	xul.dll 	nsTableOuterFrame::DestroyFrom 	layout/tables/nsTableOuterFrame.cpp:220
14 	xul.dll 	nsBlockFrame::DestroyFrom 	layout/generic/nsBlockFrame.cpp:320
15 	xul.dll 	nsBlockFrame::DestroyFrom 	layout/generic/nsBlockFrame.cpp:320
16 	xul.dll 	nsContainerFrame::DestroyFrom 	layout/generic/nsContainerFrame.cpp:272
17 	xul.dll 	nsCanvasFrame::DestroyFrom 	layout/generic/nsCanvasFrame.cpp:95
18 	xul.dll 	nsContainerFrame::DestroyFrom 	layout/generic/nsContainerFrame.cpp:272
19 	xul.dll 	nsHTMLScrollFrame::DestroyFrom 	layout/generic/nsGfxScrollFrame.cpp:122
20 	xul.dll 	nsContainerFrame::DestroyFrom 	layout/generic/nsContainerFrame.cpp:272
21 	xul.dll 	ViewportFrame::DestroyFrom 	layout/generic/nsViewportFrame.cpp:73
22 	xul.dll 	nsFrameManager::Destroy 	layout/base/nsFrameManager.cpp:257
23 	xul.dll 	PresShell::Destroy 	layout/base/nsPresShell.cpp:2023
24 	xul.dll 	DocumentViewerImpl::DestroyPresShell 	layout/base/nsDocumentViewer.cpp:4273
25 	xul.dll 	DocumentViewerImpl::DestroyPresShell 	layout/base/nsDocumentViewer.cpp:4274
26 	xul.dll 	DocumentViewerImpl::Destroy 	layout/base/nsDocumentViewer.cpp:1618
27 	xul.dll 	DestroyViewerEvent::Run 	docshell/shistory/src/nsSHEntry.cpp:879
28 	xul.dll 	nsThread::ProcessNextEvent 	xpcom/threads/nsThread.cpp:547
29 	xul.dll 	mozilla::ipc::MessagePump::Run 	ipc/glue/MessagePump.cpp:110
30 	xul.dll 	xul.dll@0xaecb2b 	
31 	xul.dll 	MessageLoop::RunHandler 	ipc/chromium/src/base/message_loop.cc:202
32 	xul.dll 	XPCNativeMember::GetCallInfo 	js/src/xpconnect/src/xpcwrappednativeinfo.cpp:102
33 	xul.dll 	_SEH_epilog4 	
34 	xul.dll 	MessageLoop::Run 	ipc/chromium/src/base/message_loop.cc:176
35 	xul.dll 	nsBaseAppShell::Run 	widget/src/xpwidgets/nsBaseAppShell.cpp:180
36 	xul.dll 	xul.dll@0xaecb2b 	
37 	xul.dll 	nsAppShell::Run 	widget/src/windows/nsAppShell.cpp:243

More crashes at: http://tinyurl.com/39mo93j

Reproducible: Sometimes
(Reporter)

Updated

7 years ago
blocking2.0: --- → ?
Version: unspecified → Trunk
frame 1 in the stack is bogus
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 599341

Updated

7 years ago
Component: General → Plug-ins
Product: Firefox → Core
QA Contact: general → plugins

Updated

7 years ago
blocking2.0: ? → ---
You need to log in before you can comment on or make changes to this bug.