All users were logged out of Bugzilla on October 13th, 2018

changing Frame-URLs only works when Frames already finsihed loading

RESOLVED WORKSFORME

Status

()

P3
normal
RESOLVED WORKSFORME
18 years ago
2 months ago

People

(Reporter: kochann, Assigned: john)

Tracking

Trunk
Future
x86
Windows 98
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

18 years ago
From Bugzilla Helper:
User-Agent: Mozilla M18 (Windows; Windows 98; en-US; m18)
BuildID:    2000111808

This page is using a menu on the left and a main-frame on the right. Clicking a 
button on the left is loading a new frameset in the right window.
The Problem: you click on a button and the frameset is loading on the right. 
Click another button WHILE the frameset is still loading is stopping the loading 
process and restarting loading the not yet finished frameset instead of the new 
clicked frameset. 
The Result: as long as the complete frameset (by clicking a button) is not 
loaded you can't change the frames anymore. You can click any button you like 
Mozilla is always loading the same frame again and again. Only waiting untill 
everything is loaded makes the buttons on the left work again.

Reproducible: Always
Steps to Reproduce:
1. in the left menu frame click on "Seminare"
2. while page is loaded click on any other left menu button
3. Mozilla is reloading the right frame but is still trying to get the  
"Seminare"-page.


Actual Results:  I got the wrong page. I got the page for "Seminare" not the 
page I selected from the left sided menu


Expected Results:  I expected to get the page of the button I clicked last and 
not first.

Comment 1

18 years ago
I am seeing this problem as well.
Mozilla Build # 2000112704 M18 Trunk Build
OS: Windows 98
Platform: PC

Marking as NEW.
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 2

18 years ago
Same bug on Linux too. Seems to be OS-independent

Comment 3

18 years ago
still present in trunk build 2001012504 using NT.

additional example url:
http://www.equiserve.com/content/invstr_services/company/index_comp.htm
also effected are nearly all the framesets within their account access
pages because something on their website never finishes downloading (no
idea what, but the throbber never stops by itself.)

apparent duplicates: 50246, 62866 and possibly 61557 but I can't reach it's
testcase (no such host according to my dns). Of the four this one has the best
description.

Updated

18 years ago
Target Milestone: --- → Future

Comment 5

18 years ago
*** Bug 60751 has been marked as a duplicate of this bug. ***

Comment 6

18 years ago
QA Contact update
QA Contact: petersen → amar
*** Bug 50246 has been marked as a duplicate of this bug. ***
*** Bug 60417 has been marked as a duplicate of this bug. ***
*** Bug 62866 has been marked as a duplicate of this bug. ***
*** Bug 69001 has been marked as a duplicate of this bug. ***
*** Bug 46959 has been marked as a duplicate of this bug. ***
Problem was first reported as bug 47117 (targetted at 0.9.1).
Bulk reassignin HTML FRAME/IFRAME bugs to Eric.
Assignee: pollmann → evaughan
Bulk re-assigning all of Eric's HTMLFrame bugs to John.
Assignee: eric → jkeiser
Can anyone still reproduce this?  It worskforme...

Comment 16

15 years ago
wfm here too.
OK, marking so.
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → WORKSFORME

Updated

2 months ago
Product: Core → Core Graveyard
Component: Layout: HTML Frames → Layout: Images
Product: Core Graveyard → Core
You need to log in before you can comment on or make changes to this bug.