Closed Bug 606056 Opened 9 years ago Closed 9 years ago

Search plugins are not loading after changing the localization to arabic using the Arabic plugin

Categories

(Firefox for Android Graveyard :: General, defect)

ARM
All
defect
Not set

Tracking

(Not tracked)

VERIFIED FIXED

People

(Reporter: nhirata, Assigned: vingtetun)

Details

Attachments

(1 file)

Mozilla/5.0 (Maemo;Linux armv71; rv:2.0b8pre) Gecko/20101020 Firefox/4.0b8pre Fennec/4.0b2pre
Mozilla/5.0 (Android; Linux armv71; rv2.0b8pre) Gecko/20101020 Firefox/4.0b8pre Fennec/4.0b2pre

1. install the latest arabic plugin [ use the install trigger ; http://people.mozilla.org/~nhirata/html_tp/installplugin.html ]
2. set fennec to Arabic; restart
3. go to the control panel and look at the plugins tab

Expected:
1. Google, Amazon.com, Twitter, Wikipedia search plugins show.

Actual:
1. None of the integrated search engines show.

Note:
1. separating from bug 605930
2. might be an issue with the localized plugin?  Italian, French, German, English all show the search plugins.
Attached patch PatchSplinter Review
The issue is because no arabic search engines has been installed in the l10n arabic build. This will be fixed by the localizer.
In all cases we should disabled the open search menu button if no search engines are available (this is what the patch does)
Attachment #485017 - Flags: review?(mark.finkle)
Attachment #485017 - Flags: review?(mark.finkle) → review+
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → FIXED
Search menu is disabled when there is nothing in the list.

Verified : 
Mozilla/5.0 (Maemo;Linux armv71; rv:2.0b8pre) Gecko/20101022 Firefox/4.0b8pre Fennec/4.0b2pre
Mozilla/5.0 (Android; Linux armv71; rv2.0b8pre) Gecko/20101022 Firefox/4.0b8pre Fennec/4.0b2pre

Need arabic search engines to be installed in the l10n arabic build.
Status: RESOLVED → VERIFIED
bugspam
Assignee: nobody → 21
You need to log in before you can comment on or make changes to this bug.