Turn the tree orange if a test leaks

VERIFIED DUPLICATE of bug 469523

Status

Testing
XPCShell Harness
VERIFIED DUPLICATE of bug 469523
7 years ago
7 years ago

People

(Reporter: jdm, Unassigned)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

7 years ago
It would be nice if tests leaking would actually be visible on tinderbox, as we could have avoided problems like bug 605908.
(Reporter)

Updated

7 years ago
Depends on: 605913
(Reporter)

Updated

7 years ago
Depends on: 605910, 605915
(Reporter)

Updated

7 years ago
Depends on: 605732, 605871
(Reporter)

Updated

7 years ago
Depends on: 532556, 605900
(Reporter)

Updated

7 years ago
Depends on: 599713, 605908
(Reporter)

Updated

7 years ago
Depends on: 605726, 605884
We've wanted this for some time, but there were persistent leaks at the time that nobody had fixed. I don't know what the status is right now. The harness should print out the leak log after every test, it just doesn't make anything orange at the moment. If you'd like to drive this to completion, that would be great!
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 469523
No longer depends on: 605908
No longer depends on: 605910
No longer depends on: 605915
No longer depends on: 605726
No longer depends on: 605732
No longer depends on: 605871
No longer depends on: 605884
No longer depends on: 605900
No longer depends on: 532556
No longer depends on: 605913
No longer depends on: 599713
V.Duplicate
Status: RESOLVED → VERIFIED
OS: Mac OS X → All
Hardware: x86 → All
Version: unspecified → Trunk
You need to log in before you can comment on or make changes to this bug.