Closed Bug 606097 Opened 9 years ago Closed 7 years ago

Intermittent layout/base/crashtests/123946-1.html, 272647-1.html | application timed out after 330 seconds with no output or | timed out waiting for onload to fire

Categories

(Core :: Layout, defect)

x86
Windows Server 2003
defect
Not set

Tracking

()

RESOLVED WORKSFORME

People

(Reporter: philor, Unassigned)

References

Details

(Keywords: intermittent-failure)

http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1287615001.1287617037.28407.gz
WINNT 5.2 mozilla-central debug test crashtest on 2010/10/20 15:50:01
s: win32-slave13

TEST-UNEXPECTED-FAIL | file:///e:/builds/moz2_slave/mozilla-central-win32-debug-unittest-crashtest/build/reftest/tests/layout/base/crashtests/123946-1.html | application timed out after 330 seconds with no output
buildbot.slave.commands.TimeoutError: command timed out: 1200 seconds without output
This appears to be a consistent failure at random places in layout:

https://bugzilla.mozilla.org/buglist.cgi?query_format=advanced&short_desc=layout%2Fbase%2Fcrashtests%20330&short_desc_type=allwordssubstr&resolution=---&resolution=DUPLICATE

The crash in this bug and the one I've just seen in 272647-1.html both have an warning before them:

WARNING: NS_ENSURE_TRUE(aListener) failed: file e:/builds/moz2_slave/mozilla-central-win32-debug/build/editor/libeditor/base/nsEditor.cpp, line 1759
TEST-UNEXPECTED-FAIL | file:///e:/builds/moz2_slave/mozilla-central-win32-debug-unittest-crashtest/build/reftest/tests/layout/base/crashtests/272647-1.html | application timed out after 330 seconds with no output

This may point to something to do with this test, in any case, these two seem the same, so combining into one bug.

http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1287661435.1287663186.26435.gz&fulltext=1#err0
Summary: Intermittent layout/base/crashtests/123946-1.html | application timed out after 330 seconds with no output → Intermittent layout/base/crashtests/123946-1.html, 272647-1.html | application timed out after 330 seconds with no output
The said warning is caused by bug 606295.  It has no significance here, as it happens during destruction of an editor object.
Summary: Intermittent layout/base/crashtests/123946-1.html, 272647-1.html | application timed out after 330 seconds with no output → Intermittent layout/base/crashtests/123946-1.html, 272647-1.html | application timed out after 330 seconds with no output or | timed out waiting for onload to fire
http://tinderbox.mozilla.org/showlog.cgi?log=SeaMonkey/1332447619.1332450077.20525.gz
WINNT 5.2 comm-central-trunk debug test crashtest on 2012/03/22 13:20:19
s: cn-sea-qm-win2k3-01
{
TEST-UNEXPECTED-FAIL | file:///e:/builds/slave/test/build/reftest/tests/layout/base/crashtests/123946-1.html | application timed out after 330 seconds with no output

SCREENSHOT: data:image/png;base64,[...]
}
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → WORKSFORME
Whiteboard: [orange]
You need to log in before you can comment on or make changes to this bug.