Certain images display in primarily purple tones when ICC colour management is enabled

RESOLVED DUPLICATE of bug 488800

Status

()

Firefox
General
--
minor
RESOLVED DUPLICATE of bug 488800
7 years ago
7 years ago

People

(Reporter: u278231, Unassigned)

Tracking

3.6 Branch
x86_64
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

7 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux x86_64; en-CA; rv:1.9.2.11) Gecko/20101013 Ubuntu/10.10 (maverick) Firefox/3.6.11
Build Identifier: Mozilla/5.0 (X11; U; Linux x86_64; en-CA; rv:1.9.2.11) Gecko/20101013 Ubuntu/10.10 (maverick) Firefox/3.6.11

A few (maybe one in seven or eight) images on the web are displaying in primarily purple tones. It seems to be caused by ICC profiles, as disabling them fixes it.

Workaround: set gfx.color_management.mode to 0.

Reproducible: Sometimes

Steps to Reproduce:
1. Load up qwantz.com (as an example that I know is affected)
Actual Results:  
The image looks like this: http://i.imgur.com/n2mUf.png

Expected Results:  
The T-Rex should be a bright green, the Utahraptor a light orange, and the Dromiceiomimus a pale yellow.

I am using an nVidia GeForce GTS 250, with the Nouveau drivers.
(Reporter)

Updated

7 years ago
Version: unspecified → 3.6 Branch

Updated

7 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 488800
You need to log in before you can comment on or make changes to this bug.